LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-17-2016, 03:57 PM   #1
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Rep: Reputation: Disabled
Can't control audio in volume


Fedora 22 home, laptop (Samsung R540)

Hi all. Tried searching no results. I installed FLdigi to control a ham radio, an Icom IC-7200. It is listening for input audio via USB, and it can hear it fine, but I can't adjust the input volume to turn it down some. The alsamixer didn't do the trick. I tried every input there. Suggestions?
 
Old 04-17-2016, 06:04 PM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ cat /proc/asound/cards

$ alsamixer -c 0
$ alsamixer -c 1
$ alsamixer -c 2
...

Many machines have multiple soundcards these days. So adjusting the one that's actually used isn't as simple.

$ pavucontrol

If you have and use pulseaudio.

Or opt for a hardware solution. I use an HP4 headphone preamp from presonus. I find that there's a certain level that the soundcard sounds best at, so having another means to adjust audio (and adjust quickly with physical knobs) has it's perks. Plus using multiple speaker sets to get an EQ that doesn't make me sad has it's perks. Yes there's software means to accomplish much of the same things. But being able to lean over and push a physical mute button for the two seconds that someone thinks that I'm listening to them has it's perks.
 
Old 04-17-2016, 07:18 PM   #3
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
Thanks, Shadow. I'm not at the radio at the minute but I might be later on tonight (or tomorrow at the latest). I'll give it a shot and bump the thread with either a yay or neigh.
 
Old 04-17-2016, 07:29 PM   #4
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
Just tried those commands. As mentioned in the original post, I went through all facets of the alsamixer console and tried every slider I could find when I was at the radio. Keep in mind the input stream I'm trying to decrease is from a USB port, so I assume that has something to do with it... thoughts?
 
Old 04-17-2016, 08:07 PM   #5
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 7,231

Rep: Reputation: Disabled
Did you hit F6 to select correct device? BTW, sometimes there are more sliders than fits the screen, arrow right will show them.
 
Old 04-17-2016, 08:12 PM   #6
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
I did hit F6, did not try going farther right than what was on the screen... more to follow
 
Old 04-17-2016, 08:55 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ amixer -c 0
$ amixer -c 1
...

Will give you more human readable information in a study-able way. So you know what you're looking for in the mixer settings.
 
Old 04-17-2016, 09:00 PM   #8
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
No joy. In the alsamixer console, when I press F6 to select a device, I see

Quote:
- default
0 HDA Intel MID
1 USB Audio CODEC
enter device name...
I cycled through the top two, including scrolling all the way to the right, and turned them all down / off and watched the FLdigi audio input waterfall. It didn't change. When I went to "1 USB Audio CODEC", there's one Playback device, which I turned all the way down, but under Capture, it just says "This sound device does not have any capture controls." It has to be somewhere, because I can change this on Windows. Maybe a permissions issue?
 
Old 04-17-2016, 10:40 PM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
The user should be in the "audio" group.

$ groups

alsamixer has F1 for help, but normally press tab twice to get ALL the channels. Use the arrow keys to move around and adjust, M to unMute and Mute. Sometimes you have to change other things to make some channels visible. But since you're already getting sound that's probably not something that affects you.

What is acting as your speakers? My monitor has audio input and speakers. But the volume control for those are in the monitors menus. Since I feed it from a hardware solution I also have volume control on the preamp and on the audio device in software.
 
Old 04-18-2016, 08:22 AM   #10
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
So it's sort of a strange situation (to this forum, anyway). I'm a ham radio operator. I have a radio called the IC-7200. The radio is connected to the computer via USB so I can use the program FLdigi and take advantage of the radio's digital data modes, like PSK31, RTTY, JT65, even computer-controlled CW (Morse code).

The computer needs to accept audio input from the USB source (the radio) and also put audio back out through the USB to transmit data, so the "speakers" right now are set up as the USB. I think that works. When I get home, I'm going to take another radio I have and tune it to the IC-7200's frequency, turn on FLdigi and have it transmit my call sign to see if it is being put out properly.

I'll check groups tonight when I'm off work and add myself if I need to. Thanks for everything so far.
 
Old 04-18-2016, 08:28 AM   #11
Operator
Member
 
Registered: Aug 2015
Location: Virginia
Distribution: RHEL 5, Fedora 22
Posts: 46

Original Poster
Rep: Reputation: Disabled
Maybe I'll take a video of the setup.

edit: Possible clue? https://github.com/df8oe/mchf-github...g-usb-cataudio

Quote:
Enabling/Disabling USB CAT/AUDIO.
•In the Configuration menu is entry 220 CAT-MODE (Configuration->CAT Mode). You have to set this to ON. This setting is stored permanently in the configuration. You only have to enabled it once, store the configurations e.g. by normal power-off.
•Connect your PC to the mini-USB port.

•Linux machines will now automatically detect both the virtual com port as /dev/ttyACM? and also the audio is automatically detected. Depending on the Linux sound package you are using, you may not see the capture device (sound in) in all programs. Pulse Audio does work, ALSA seems to have trouble seeing the capture interface. This may improve in future. Make sure that not programs like "modemmanager" access your device. See FAQ below.


•Windows machines should load the audio in and out driver without problems. However, the virtual COM port needs special care on all Windows Version upto and including Windows 8.1. Windows 10 loads the right drivers automatically. All Windows version from XP on can operate the serial after installation of a "special" driver information file. See below for instructions.

Last edited by Operator; 04-18-2016 at 08:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulse Audio Volume Control gymnart Linux - Software 3 10-25-2012 03:41 PM
Gnome: control audio volume via the keyboard i92guboj Linux - Desktop 2 10-04-2010 04:28 AM
Fedora 10 no control over audio volume zeelog Fedora 4 09-15-2009 11:42 AM
Problem with maximum audio volume + volume control threshold mensch Debian 6 10-10-2008 11:48 AM
Playlists and audio volume control in Xine greengrocer Linux - Newbie 1 07-26-2008 07:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration