LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-26-2004, 02:24 AM   #1
abapdr
LQ Newbie
 
Registered: May 2004
Posts: 10

Rep: Reputation: 0
Question Can't connect to Apche with https - locally it's OK


Hi Gurus,

Here we go with the first post...
Background: Mandrake 10.0 Community

I have successfully(?) installed Apache (2.0.49) on my machine, compiled it from source enabling openssl (0.9.7d). Created the self-signed certificate and hoped that I would be able to connect to my site through https. Not so!

I have a DNS server running on the same box NS1 and NS2 on two different static IPs (1.2.3.4 and 5.6.7.8).
Netstat and nmap tell me that both port 80 and 443 are open and listening.

I CAN successfully connect to my site through the following methods:
--locally:
http_://localhost
http_://www_mydomain.com
http_://1.2.3.4
http_://5.6.7.8
https_://localhost
https_://www_mydomain.com
https_://1.2.3.4
https_://5.6.7.8

--from a different machine not on a network with the server:
http_://www_mydomain.com
http_://1.2.3.4
http_://5.6.7.8

I CAN NOT connect to my site from a different machine with https_://www_mydomain.com
https_://1.2.3.4
https_://5.6.7.8
I get the boring "Cannot find server" page.

Any help would be much appreciated! Thanks for your input,
abapdr
 
Old 05-26-2004, 03:16 AM   #2
zeropash
Member
 
Registered: Apr 2003
Location: Bangalore,India
Distribution: FC2, RHES, RH9, FC3, FC1, Slackware 3.0
Posts: 208

Rep: Reputation: 30
I think the problem could be caused by the firewall option.
the http is open but https is not. this would mean that you can connect locally but not remotely.
i dont know how to do that in mandrake (redhat had some lokkit for this or you can use iptables from command line to allow https incomming traffic).
 
Old 05-26-2004, 03:37 AM   #3
abapdr
LQ Newbie
 
Registered: May 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Question Can't connect to Apche with https - locally it's OK

Thanks zeropash.

In my iptables I do not drop the packets coming through eth0 on tcp port 443. The only packets I drop are tcp 111, 139, 143, 445, 3306, 5801, 6001.

abapdr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd server: can connect locally, not remotely propz Linux - Networking 2 10-24-2005 12:59 AM
Unable to connect to internet with SIS900 but able to ping locally kevinevans Linux - Networking 4 08-10-2004 01:16 PM
ProFTPd - can connect locally but...Could it be that Verizon DSL does not allow port cevjr Linux - Networking 5 02-22-2004 04:42 PM
Unable to connect to SSL with https : // ohe Linux - Security 5 11-07-2003 01:31 AM
cant connect to glftpd even locally darazman Linux - Software 1 09-06-2003 08:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration