LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-27-2008, 08:59 PM   #1
bigtoque
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Can't compile GTK+ because it thinks I've got the wrong version of Glib?


I just loaded Yellowdog 6 on my PS3 and I've been having a heck of a hard time trying to get things like swfdec working.

Anyway, I'm trying to compile the latest version (.72) and get an error telling me

"glib-2.0, gobject-2.0 and gthread-2.0 >= 2.16 are required to build swfdec" So I download, compile and install glib 2.16.5.

I just tried installing GTK 2.12 (no real reason, I'm just taking a stab in the dark and hoping the swfdec error goes away by updating to the newest GTK)and I get an error saying

"Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.12.3"

If I just installed glib 2.16.5, why is being reported as 2.12.3? How would I fix this?
 
Old 07-27-2008, 09:39 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,815
Blog Entries: 1

Rep: Reputation: 261Reputation: 261Reputation: 261
I would guess your original glib (v 2.13.5) is installed in /usr and when you installed glib-2.16.5 you installed it in /usr/local. Add /usr/local/lib/pkgconfig to your PKG_CONFIG_PATH variable and see if that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk+2.0 installation problem(older glib version ) anirudh.iitm Ubuntu 1 08-16-2006 02:37 PM
glib version missmatch. trying to install gtk+ sivart Linux - Software 5 03-25-2006 02:57 PM
GTK+ compile error : glib-mkenums Sjaaksken SUSE / openSUSE 6 12-11-2005 04:16 PM
gtk keeps finding the wrong version of glib slzckboy Linux - Software 5 10-21-2005 09:26 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration