LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-22-2007, 12:30 PM   #1
werner1975
Member
 
Registered: Jun 2007
Posts: 43

Rep: Reputation: 15
Can't compile gnome-ppp on my openSUSE Gnome computer


Hello,

I downloaded the source code of gnome-ppp and when I run ./configure inside the directory, I get this error message:
Code:
checking pkg-config is at least version 0.9.0... yes
checking for DEPS... configure: error: Package requirements (gtk+-2.0 >= 2.4.0 libglade-2.0 >= 2.4.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the DEPS_CFLAGS and DEPS_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
I'm using the latest version of openSUSE Gnome (10.3), updated from today with Gtk+-2.12.0 and libglade 2.6.2... Any idea?
Thanks,

Last edited by werner1975; 10-22-2007 at 12:37 PM.
 
Old 10-23-2007, 05:36 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,813
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Install the developer packages for Gtk and libglade using your package manager. They will be named something like gtk-dev or gtk-devel and libglade-dev or libglade-devel.
 
Old 10-23-2007, 12:25 PM   #3
werner1975
Member
 
Registered: Jun 2007
Posts: 43

Original Poster
Rep: Reputation: 15
Bingo
It's working great now. The only think I need to do is add the sticky bit so that I don't have to run it as root
Thanks.
 
Old 10-23-2007, 02:07 PM   #4
werner1975
Member
 
Registered: Jun 2007
Posts: 43

Original Poster
Rep: Reputation: 15
It seems Gtk applications don't work with suid. Any suggestion to circumvent this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PPP GUI for openSUSE/Gnome? werner1975 SUSE / openSUSE 3 10-20-2007 10:14 AM
gnome-ppp Overview Ubuntu 1 11-20-2005 05:26 AM
Gnome PPP permissions otis2003 Linux - Networking 0 06-20-2005 04:04 PM
Can't dial with gnome-ppp pen^2 Linux - General 2 11-05-2003 06:15 AM
how to dock ppp in gnome? spyghost Linux - Software 1 09-03-2003 02:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration