LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Caja (Mate file manager) cannot write to USB (https://www.linuxquestions.org/questions/linux-software-2/caja-mate-file-manager-cannot-write-to-usb-4175590095/)

haertig 09-24-2016 07:39 PM

Caja (Mate file manager) cannot write to USB
 
I ran into one I don't understand. I have a microSD card that Caja cannot write to. Caja says "The destination is read-only". LinuxMint18, Mate desktop, Caja version 1.14.1

Except it's not read-only. I can write to it just fine from the command line using the same userid that Caja is using. Oddly enough, Caja could write to this microSD card just fine last week (I used drag-n-drop to add files to it). I unmounted it and ran dosfsck (since it's formatted vfat). All looks good there. And the mount parameters look good:

Code:

david@Davids-Linux-Desktop ~ $ mount | grep sde1
/dev/sde1 on /media/david/4AFA-9B15 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
david@Davids-Linux-Desktop ~ $

Code:

david@Davids-Linux-Desktop ~ $ umount /dev/sde1
david@Davids-Linux-Desktop ~ $ sudo dosfsck /dev/sde1
[sudo] password for david:
fsck.fat 3.0.28 (2015-05-16)
/dev/sde1: 7 files, 8/236096 clusters
david@Davids-Linux-Desktop ~ $

Any ideas?

haertig 09-24-2016 08:31 PM

Well, I fixed it.

I was going to try running caja as root to see if that helped. Before doing that, I ran a ps and noted that caja was already running (as my normal userid). even though there were no caja windows being displayed.

So I typed "caja --quit" from the command line. No visual difference on the screen, since no windows were displayed in the first place. But it killed the process.

Now, everything works fine. When I start Caja the normal way, by clicking on a desktop icon, it can write to the microSD card.

That was a weird one!


All times are GMT -5. The time now is 06:14 AM.