LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2017, 07:20 PM   #1
lucmove
Senior Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Stretch
Posts: 1,110

Rep: Reputation: 85
Burning with cdw: file names are too long, try "Long Joliet file names"


I am trying to burn a CD with cdw. The program refuses, and says:

Can't create image: some file names are too long. Try toggling "Long Joliet file names" checkbox in ISO9660 options.

I can't find that option anywhere, either in the program or the man page. Google doesn't seem to have seen that error message either.

I'm stumped.
 
Old 01-29-2017, 09:05 PM   #2
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17
cdw is a frontend, so the problem is most likely in another program.

But here is what I would suggest

1. You need to set the ISO level to level 3. Hopefully there is an option in CDW for that.
2. You can set this option in the program it calls via an alias or some config file.
3. Ask the author of cdw http://cdw.sourceforge.net
4. Make all your filenames 8.3 (dos).

Cheers,

Gary
 
Old 01-30-2017, 08:08 AM   #3
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 4,215

Rep: Reputation: Disabled
Sounds like the CD wasn't created with the Joliet option enabled.

Check out the options in the man page of the software you used to create the iso image.
 
Old 02-21-2017, 06:06 AM   #4
lucmove
Senior Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Stretch
Posts: 1,110

Original Poster
Rep: Reputation: 85
I contacted the author and he replied:

1. make sure that you have mkisofs or genisoimage package installed.
2. start cdw, in main window go to Configuration,
3. in Configuration window go to Tools tab, check "Configure tools manually" checkbox.
4. in the Tools tab you now should see few drop-down menus. Make sure that selection in first, second and maybe third menu includes "mkisofs" (or "genoisomiage").
5. press "F9" to save and close Configuration window,
6. select files that you want to burn,
7. select "Write files to disc" option,
8. in "Write wizard" there is "Other options" button near the bottom, select it.
9. in "Write options" window go to ISO9660 tab, there should be "Long Joliet file names" checkbox. Select it, press F9 to save ISO9660 options.

It helped. Problem solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Long file names on Linux file server jumbled when opening on 16-bit PC program. brandonhughesj General 3 03-04-2009 07:53 AM
Fat32 Long file names cppkid Programming 1 07-29-2005 04:01 AM
long file names; fatso32 itzfritz Linux - General 7 11-14-2004 06:56 PM
dosfs and long file names Ipolit Slackware 3 12-08-2003 01:36 PM
Long File Names Pwcca Linux - General 1 03-05-2003 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration