-   Linux - Software (
-   -   Burn Centos 6.8 iso to USB stick (

timl 12-31-2016 10:20 PM

Burn Centos 6.8 iso to USB stick
I must be missing something simple here. I downloaded the Centos iso. I get the following files on my F25 system:


[tim@comedian ~]$ ls CentOS-6.8-x86_64-LiveDVD/
CentOS-6.8-x86_64-LiveDVD.iso sha1sum.txt sha256sum.txt.asc
md5sum.txt sha1sum.txt.asc
md5sum.txt.asc sha256sum.txt
A quick sanity check:


[tim@comedian ~]$ cat CentOS-6.8-x86_64-LiveDVD/md5sum.txt
f73c2c4dd333c202ca85ea66120cacdf CentOS-6.8-x86_64-bin-DVD1.iso
cdd5b1c1af837774f4fa3a105365a218 CentOS-6.8-x86_64-bin-DVD2.iso
79c7924015d842857fb8177e4b788b8b CentOS-6.8-x86_64-LiveCD.iso
b27e5eef3008fcd7069ac72d113e85d2 CentOS-6.8-x86_64-LiveDVD.iso
0ca12fe5f28c2ceed4f4084b41ff8a0b CentOS-6.8-x86_64-minimal.iso
9e0ee4c5d9d0371fa0c0809b487ee5bb CentOS-6.8-x86_64-netinstall.iso
[tim@comedian ~]$ md5sum CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso
b27e5eef3008fcd7069ac72d113e85d2 CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso

[tim@comedian ~]$ cat CentOS-6.8-x86_64-LiveDVD/sha256sum.txt
1dda55622614a8b43b448a72f87d6cb7f79de1eff49ee8c5881a7d9db28d4e35 CentOS-6.8-x86_64-bin-DVD1.iso
0aba869427b4ce04e100d72744daf7fea1f7be2e4be56b658095bd9e99e04e6d CentOS-6.8-x86_64-bin-DVD2.iso
efa82d673206cb6af377b1f929a510cc2b1ce95cdb436210121ec271e056c920 CentOS-6.8-x86_64-LiveCD.iso
52a9c8c1d250de39976dda9412293473b8349efefb31b66fecdee0fdf93866d9 CentOS-6.8-x86_64-LiveDVD.iso
ec49c297d484b9da0787e5944edc38f7c70f21c0f6a60178d8e9a8926d1949f4 CentOS-6.8-x86_64-minimal.iso
56d9cc5757ed1443af7b321967622a108978328f72e58050d31bcf1998dfd162 CentOS-6.8-x86_64-netinstall.iso
[tim@comedian ~]$ sha256sum CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso
52a9c8c1d250de39976dda9412293473b8349efefb31b66fecdee0fdf93866d9 CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso
So far so good. Now I write to USB


sudo dd if=CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso of=/dev/sdd bs=4M
Make a coffee while the iso writes. When I eject and reconnect the USB stick, it is not visible via F25. I have tried 2 USB sticks and


sudo dd if=CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso of=/dev/sdd
sudo dd if=CentOS-6.8-x86_64-LiveDVD/CentOS-6.8-x86_64-LiveDVD.iso of=/dev/sdd bs=1M
With the same result everytime. Maybe it is the heat and the Christmas cheer but if anyone could spot anything obvious I would be grateful


Rava 12-31-2016 10:52 PM

I only used the "copy iso to usb stick and erase all data on useb stick) only once, and that was an OS that would work no other way. So I do not have much of advise to give you to make it run your way, but I can give you an alternate way.

Usually I try to make it work as copying the iso as iso file and then address that iso in the bootloader file, e.g. like so for Puppy fatdog iso:

LABEL Fatdog64 7.00 via memdisk
KERNEL memdisk
INITRD boot/Fatdog64-700.iso
Run fatdog from ISO file
via memdisk (part of
or Slax iso:

MENU LABEL Slax from iso
KERNEL /slax/boot/vmlinuz
APPEND from=/boot/slax-7.0.8-x86_64.iso vga=normal initrd=/slax/boot/initrfs.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 slax.flags=perch,xmode timezone=Europe/Bratislava
Run Slax
from local ISO file
As you can see, there are different ways to make the ISO bootable, depending on the bootloader and ISO. In very rare occasions it might even be necessary to extract the kernel and initrd so that the booting works, but usually that is not needed.

smallpond 12-31-2016 11:02 PM

What does "not visible" mean? What is the result of

mkdir /tmp/foo
mount /dev/sdd1 /tmp/foo

herkalurk 12-31-2016 11:16 PM


timl 12-31-2016 11:20 PM


Originally Posted by smallpond (Post 5648744)
What does "not visible" mean? What is the result of

mkdir /tmp/foo
mount /dev/sdd1 /tmp/foo

Thanks. The volume is write protected! This gives me something to play with


[tim@comedian ~]$ sudo mount /dev/sdd1 /tmp/foo
mount: /dev/sdd1 is write-protected, mounting read-only
[tim@comedian ~]$ ls /tmp/foo/
EFI GPL isolinux LiveOS

timl 01-01-2017 10:32 PM

Sorry, no joy with this. Can anyone advise either:
  • why the drive becomes write protected after using dd (I tried again after reformatting and same issue)? Or
  • is there a way to remove the read only state?

yancek 01-02-2017 07:01 AM

I'm not sure what you are expecting? You indicate in your initial post that the iso is not visible in Fedora after creating the bootable usb but the output you posted after following the suggestions of 'smallpond' clearly show the expected directories.


[tim@comedian ~]$ ls /tmp/foo/
EFI GPL isolinux LiveOS
The flash drive doesn't become write protected because of your use of dd, it becomes write protected because you are putting an iso9660 filesystem on it which is write protected by design. What exactly are you trying to accomplish? Have you tried booting the flash drive since that is generally the purpose of using dd on an iso?

You can't 'remove' the read-only state, what you can do if you want to modify is copy the directories/files to another directory and modify them and then re-create the iso. Again, I'm not sure what your intentions are?

timl 01-02-2017 04:02 PM

Looks like I need to go back to "how to write a decent question" class. For a few years now I have used dd to burn isos to USB sticks. I have got a level of confidence now and I simply plug the USB stick into the relevant computer and have a play with the live distro before installing.

This time the computer recognised that a USB stick was present but did not boot from it. When I brought the stick back to my F25 computer I could see no trace of the stick and then we get back to post #1. I also tried unetbootin with no joy.

The requirement for the ISO goes back to a dead Centos disk. When I get a new motherboard I will try Centos 7. In the meantime I will use Fedora server (which I can successfully transfer to USB). The thread is thus solved :)

RockDoctor 01-03-2017 12:17 PM

I find that for some unknown reason, some usb sticks containing dd'd iso images don't automount but do show up when running blkid (as root)

~$ sudo blkid -c /dev/null
. When a dd'd iso image won't boot, running isohybrid on a copy of the iso file, then dd-ing the isohybridized copy to the usb stick, sometimes gives good results

All times are GMT -5. The time now is 12:13 PM.