-   Linux - Software (
-   -   Building GCC 4.1.X, How To fix (

jiobo 12-04-2008 02:54 AM

Building GCC 4.1.X, How To fix "" Error 1
WARNING: `makeinfo' is missing on your system. You should only need it if
you modified a `.texi' or `.texinfo' file, or any other file
indirectly affecting the aspect of the manual. The spurious
call might also be the consequence of using a buggy `make' (AIX,
DU, IRIX). You might want to install the `Texinfo' package or
the `GNU make' package. Grab either from any GNU archive site.
make[3]: *** [] Error 1

This is the error that I was getting when trying to compile and build GCC 4.1.X following the directions given by GNU in the INSTALL directory with HTML pages. There is an error with the scripts that create the directories for the "fastjar" package, and I had to edit the Makefile to include the directory for the "makeinfo" package, which it incorrectly said that it was not on my system!

> which makeinfo

> makeinfo --version
makeinfo (GNU texinfo) 4.11

Copyright (C) 2007 Free Software Foundation, Inc.

In the "fastjar" directory, there is a Makefile with the MACRO "MAKEINFO =" and it had the term "missing" in it, indicating that it was not found. I added it, and then built fastjar issuing the command "make" in the <objdir>/fastjar directory. It built. Then, I redid the build of GCC and it did not give the "fastjar" error.

I also found a fastjar page on, and the author looks to be a busy student!

knudfl 12-05-2008 08:02 AM

It's a very rare error, probably with a very rare
combination of config options.

Doing 'cd build-gcc-here' and

../gcc-4.1.2/configure --enable-clocale=gnu --enable-shared \
--enable-threads=posix --enable-__cxa_atexit \
--enable-languages=c,c++,fortran,java --disable-libstdcxx-pch

will make no errors by compiling.

But omitting the build directory outside gcc,
some random errors can and will occur.

All times are GMT -5. The time now is 10:43 AM.