LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-31-2003, 06:21 AM   #1
radhapriya
LQ Newbie
 
Registered: Mar 2003
Posts: 27

Rep: Reputation: 15
Building cross-compiling toolchain


Hi,
I am having Redhat linux 8.0 (2.4.18-14). My software development is based
on ARM processor(Intels xscale PXA255). I want a cross-compile toolchain. As I want the recent
versions I didnot prefer precompiled toolchain. I want to build the toolchain
with new versions. I followed the instructions from

http://www.allis.de/~k/knowlwdge/cro.../toolchain.php

I got the following
binutils-2.13.2.1.tar.gz
patch-2.4.19-rmk7.gz
diff-2.4.19-rmk7-pxa2.gz
gcc-3.2.3.tar.gz
glibc-2.2.5.tar.gz
glibc-linuxthreads-2.2.5.tar.gz
glibc-2.2.5-2.3.diff.gz
from ftp://ftp.gnu.org/

Compiling till GCC works fine.
I configured Glibc with
./configure arm-linux --target=arm-linux --prefix=/usr/local/arm-linux
--enable-add-ons. This goes fine

When i run "make", the error message is:

[root@instec glibc-2.2.5]# make
./aclocal.m4:19: error: m4_defn: undefined macro: _m4_divert_diversion
aclocal.m4:33: AC_CHECK_SYMBOL is expanded from...
./aclocal.m4:19: the top level
make: *** [sysdeps/unix/common/configure] Error 1

I have the autoconf-2.53-8
automake-1.6.3-1
m4-1.4.1-11

Help me to solve this problem.
 
Old 06-25-2004, 12:01 AM   #2
altosys
LQ Newbie
 
Registered: Jun 2004
Posts: 6

Rep: Reputation: 0
Hey,
I'm facing the same problem. However my target platform is i386. i.e., Im trying to build a small Linux sytem on a 64MB partition of my HDD.
Thus, my host is i686 and my target is i386

After compiling binutils, while compiling bootstrap compiler gcc , I'm getting the following errors during make :

make[2]: *** [libgcc/./unwind-dw2.o] Error 1
make[1]: *** [libgcc.a] Error 2
make: *** [all-gcc] Error 2

Can this be a version mismatch problem between gcc, glibc and binutils ???

Does anyone know the EXACT versions and patches for binutils, gcc, glibc for an i386 GNU toolchain?

Thanks in advance,
Raseel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error building cross gcc-3.3.2 for i386-mingw32msvc target ugenn Linux - Software 2 10-05-2012 02:33 AM
Cross Compiling dosnlinux Programming 5 03-01-2006 11:12 AM
Building cross-compiler gcc for powerpc-linux ccool Linux - General 3 09-17-2004 06:33 AM
Cross-Building Slackware as a whole? gargamel Slackware - Installation 2 05-09-2004 06:31 PM
Building an ARM7 cross compiler from gcc Charlie_B Linux - Software 2 08-20-2003 08:59 AM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration