-   Linux - Software (
-   -   Build problem - ./configure output saying package is not present when it is. (

spoovy 04-06-2011 12:55 PM

Build problem - ./configure output saying package is not present when it is.
I'm trying to build xfce 4.8 from source on Scientific Linux 6.0. Following the instructions here - - All is fine until I come to configure xfce4-panel when I get the following error. Note that I have successfully built and installed the supposedly missing package in several locations.


checking for pkg-config... /usr/bin/pkg-config                                                                                                     
checking for pkg-config >= 0.9.0... 0.23                                                                                                           
checking for libxfce4util-1.0 >= 4.8.0... 4.8.1                                                                                                     
checking LIBXFCE4UTIL_CFLAGS... -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include                                           
checking LIBXFCE4UTIL_LIBS... -lxfce4util -lglib-2.0                                                                                               
checking for garcon-1 >= 0.1.5... 0.1.5
checking GARCON_CFLAGS... -pthread -I/usr/include/garcon-1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking GARCON_LIBS... -pthread -lgarcon-1 -lgio-2.0 -lgthread-2.0 -lrt -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
checking for libxfce4ui-1 >= 4.8.0... not found
*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.8.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
[spoovy@kermitsl xfce4-panel-4.8.0]$ sudo find / -name libxfce4ui-1
[spoovy@kermitsl xfce4-panel-4.8.0]$

Any help gratefully accepted.


Snark1994 04-06-2011 01:42 PM

It will be looking for a ".pc" file to say that the package is installed, if you're using pkgconfig... Try

sudo find / -iname *.pc | grep libxfce

bathory 04-06-2011 01:42 PM


What was the PREFIX you used to build the initial components? If it was /usr/local (or you didn't used a --prefix) then you should use:

export PKG_CONFIG_PATH=/usr/local/lib/pkconfig:$PKG_CONFIG_PATH
Or change the path to pkgconfig accordingly.
You can also try to find libxfce4ui-1.pc and use that pathin PKG_CONFIG_PATH


spoovy 04-06-2011 02:27 PM

Thanks guys. The .pc file(s) are present alright. I tried your edit to my PKG_CONFIG_PATH bathory and it worked (once i'd spotted your deliberate typo that is :)

Thanks again.

spoovy 04-06-2011 02:38 PM

On reading further down the xfce instructions page I see this was covered. I must read the whole page before starting!!

Snark1994 04-07-2011 05:07 PM

Well done for fixing it, now just mark the thread as SOLVED :)

All times are GMT -5. The time now is 09:04 AM.