LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-14-2007, 06:06 PM   #1
_slo
LQ Newbie
 
Registered: Jan 2007
Distribution: debian(home), rhel(work)
Posts: 5

Rep: Reputation: 0
btg configure problem


Hi all
I was trying to to configure BTG 0.9.5 (bit torrent daemon with various front-ends http://btg.berlios.de) with CLI and GUI front-ends. I'm runnig debian etch (2.6.18). So i installed necessary packages for btg and begin to configure it. As a result i got:

configure: Link test, compiler flags: -pthread -I/usr/include -I/usr/include
configure: Link test, linker flags :
-lboost_iostreams -lboost_filesystem -lboost_date_time
-lboost_thread -lboost_program_options
-ltorrent -lgnutls
checking if BTG can link with the provided/found libraries... no


I've seen btg howto (http://btg.berlios.de/howto-0.9.6.html), where this problem was discussed, but i just can't understand what the way i need "to adjust CXXFLAGS and LDFLAGS before running configure". Can someone tell me what should i do or what i did wrong?

Thanx for the attention to my problem.
 
Old 12-15-2007, 11:03 AM   #2
kzutter
Member
 
Registered: Nov 2007
Location: Carson City, NV USA
Distribution: Various, but always Debian based
Posts: 70

Rep: Reputation: 15
Are you trying to build this from source or are you installing from .deb packages?

The .deb packages are pre-built and you do not configure them.

The reason I ask is that the howto you pointed to is confusing and makes it sound like you have to do configure after downloading packages. This is mis-leading.
 
Old 12-16-2007, 05:33 PM   #3
sztricskoj
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
Hi!
I think you must use rb_libtorrent-devel instead of libtorrent-devel or torrent-devel package. I think...
 
Old 12-17-2007, 02:11 PM   #4
_slo
LQ Newbie
 
Registered: Jan 2007
Distribution: debian(home), rhel(work)
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, i'm trying to build it from source. Looking at the apt-cache libtorrent libraries are the only.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure problem with qt powadha Debian 2 01-09-2007 04:53 PM
./configure problem neurotic85 Linux - Software 6 09-07-2005 08:50 PM
Problem with ./configure Chtiman Linux - Software 1 01-04-2005 10:53 AM
./configure problem ! wlaw Linux - Newbie 8 06-24-2004 07:11 AM
./configure problem Insomnia Linux - General 5 05-22-2004 09:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration