LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   BSNL Broadband MT882 USB configuration (https://www.linuxquestions.org/questions/linux-software-2/bsnl-broadband-mt882-usb-configuration-376627/)

hari77gct 10-25-2005 03:37 AM

BSNL Broadband MT882 USB configuration
 
Hi linux techies,

I am trying to configure ASDL router+modem in linux, but it vain.

I am using NLD (version of Suse) kernel 2.6.x
It has the driver to the router+modem and it detects as eth0 device once I plugs in the USB. (I dont have a lan card)

I configured the eth0 with ip 198.162.1.100 and 255.255.255.0, I also setted the nameserver & added a new gateway using
route add default gw 192.168.1.1 dev eth0.
But still I could not able to ping to the gateway 192.168.1.1 & as well no internet.

I tried arp -nVD, it says the HW addr for 192.168.1.1 is unknown.
I did a dmesg and got the HW and setted up using arp, even then after that I could not ping the gateway.

The US router+modem is working fine in windows


Please let me know your views/suggestions,


Thanks,
Hari

anilbh 10-25-2005 04:04 AM

Hi ,
I also tried installing the MT882 in Linux FC3 with kernel 2.6.... it is recognised but I could not get it to function.
the Gateway address never changes from an 10.112.112.113 I think.
This did work on Fc1 with a kernel 2.4.19...nptl .
You have to compile the CDCEther module according to instructions.
But this kernel gave problems with my HP PSC1315 Multi function printer.
Anil

hari77gct 10-25-2005 04:11 AM

I guess the driver is for 2.4.x kernels,
in 2.6 it automatically detects, should i need to conpile the driver again?

dmesg says:
eth0 registered........CD Ether..


All times are GMT -5. The time now is 03:11 PM.