-   Linux - Software (
-   -   Browser video stuck on fast-forward (

philwynk 09-08-2010 09:41 AM

Browser video stuck on fast-forward
Ok, I'm stumped.

Starting sometime last night, without any intervention that I recall, suddenly any video being played by my browser ate 100% of the cpu (npviewer was taking 85% when I viewed using "top") and would not play properly.

I uninstalled firefox, vlc, xine, mplayer, flash-plugin, pulseaudio... really, everything I could imagine was involved. I reinstalled firefox, pulseaudio, and flash-plugin.

So, now it's not eating 100% of the cpu when I run a video. Instead, it's stuck on fast-forward -- it skips huge hunks of the video, blows through it at double- or triple-speed, and of course the audio comes in jerky little bursts that are incomprehensible because I've lost frames.

Apparently there's some configuration detail that I have to feed it to slow it down to standard speed. Only, I've been running Fedora here since 2007 and have never had to do this before. WTF?

Configuration details:

- Fedora core 13 64-bit version
- Running on an Athlon 64 @about 2.2 ghz (pretty fast -- can't imagine that I'm really overpowering the cpu)
- Firefox Mozilla/5.0 (X11; U; Linux x86_64; )
- Shockwave Flash 10.1 r82
- Currently have NO audio or video package installed outside of firefox (no Xine, no Totem, no Mplayer, no VLC)

What the heck is going on here? And how best should I restore just, plain ordinary playback capabilities to my machine?

smoker 09-08-2010 03:07 PM

Were there any updates last night before this started ? Have a look at yum history and see if you might reverse the changes.

philwynk 09-08-2010 06:55 PM

I don't think that's it.
The following updates took place automatically, by way of a cron script that I execute in the middle of the night:

Sep 08 04:40:30 Updated: 1:NetworkManager-glib-0.8.1-6.git20100831.fc13.x86_64
Sep 08 04:40:35 Updated: 1:NetworkManager-0.8.1-6.git20100831.fc13.x86_64
Sep 08 04:40:36 Updated: usb_modeswitch-1.1.4-1.fc13.x86_64
Sep 08 04:40:38 Updated: usb_modeswitch-data-20100817-1.fc13.noarch
Sep 08 04:40:50 Updated: 1:NetworkManager-gnome-0.8.1-6.git20100831.fc13.x86_64

I can't see any of those causing the problem I've described.

Phil W.

John VV 09-08-2010 09:05 PM

this was only for no line videos in firefox ? right
And not for ALL videos playing in totem, or mplayer/gmplayer/SMplayer-qt4 or vlc

just the online .

if so as i recall there was and is a bug in the 64bit flash

seeing as this" Currently have NO audio or video package installed outside of firefox (no Xine, no Totem, no Mplayer, no VLC)"
there is NO way to check if vlc,mplayer and the installed by default totem work fine

how then ARE you watching videos online without the
totem ff plugin( i do not use it),
or the mplayer ff plugin(,,,,,
or the gstreammer - xine ff plugin(
or the vlc ff plugin (

can you please post the firefox output of

so we can see just how you are watching videos on line

philwynk 09-08-2010 11:05 PM

Okay. Weird.
It affected both firefox and Opera, although it was not nearly as bad in Opera.

John VV makes a good point, so I went ahead and installed mplayer to test it from the command line. The result was that not only did mplayer handle the video just fine and dandy, but after I installed mplayer firefox ALSO handled the audio and video properly... and so did Opera.

I'm sure I should be learning something about the operation of these multimedia programs from this incident. I'm guessing that firefox gives preference to mplayer over the shockwave plugin, and mplayer contains controls for the audio/video components of my machine that do a better job of buffering than does shockwave.

Anyhow, it appears that I can now play multimedia files again, so... thanks for your help, all.

Just FYI, since you asked, though:

about : plugins

Shockwave Flash 10.1 r82
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

NPAPI Plugins Wrapper 1.3.0


IcedTea NPR Web Browser Plugin (using IcedTea6 1.8.1 (fedora-42.b18.fc13-x86_64))


followed by a mime type for every java version...

John VV 09-09-2010 02:24 AM

for fedora this is a very very good help/guide page
it is short and right to the point
and very useful

philwynk 09-09-2010 07:30 AM

John VV, I think you misread...
John, thanks for the link. I'm already pretty familiar with that page, and I think you missed the part of the post that started this thread in which I said that I had, just the previous night, REMOVED pulseaudio, mplayer, vlc, and xine in an attempt to find out what was eating my cpu. That means I had all of them installed until about 2 nights ago. I was using one or more of the above to view videos, and they were working just fine until the other night. It was the sudden influx of "Oh, s**t, that isn't working for some reason" that started the current mess.

Thanks again for your help.

MTK358 09-09-2010 07:42 AM

If this is solved, mark the thread as solved.

wytcld 06-21-2012 11:44 AM

In my case Flash videos were racing ahead because of a sound setting. They'd started racing ahead at download speed after upgrading Ubuntu to 12.04.

Found the problem. It's an odd one. Looking in the Volume Control app (not sure if it's a Gnome or Xfce thing - desktop is Xfce), it showed that it has been defaulting to trying to play the audio stream through "Redwood HMDI Audio" on account of seeing a Radeon video card in the system. Turning that off under the Configuration tab and having Built-in Audio set to the appropriate (in my case) Analog Stereo Audio not only restores sound, but it fixes the Flash-video-racing-ahead problem.

What's insane is that video should race ahead because of a non-functioning audio output. How could Adobe have ever programmed Flash with that dependency?

In any case it appears that in the upgrade cycle Ubuntu insisted on bringing HDMI audio back into play. That had been set correctly - off - before the upgrade. I do have HDMI to my monitor, but its speakers are analog.

So if Flash videos race ahead, see if adjusting your sound settings fixes it.

Idiosyncra3y 08-11-2012 03:09 AM

Thank you wytcld. Exactly the same problem here, and exactly the same fix.

Fedora 17 here.

All times are GMT -5. The time now is 09:26 PM.