-   Linux - Software (
-   -   Broken gnome and terminal (

gsv666 12-21-2008 09:31 AM

Broken gnome and terminal
Hey everyone...

Some help is needed if possible...

My computer is an Asus X52S laptop with Core2 Duo and the N-Vidia 8600M GS... running Hardy Heron (8.04) with some other packages from Ubuntu Studio and some custom installs. Using gnome (obviously= Ubuntu) with Compiz and Emerald. The installation worked straight out of the box for most things... including wireless internet... has been really stable and handles most everything I throw at it. Because of the Audio work that I do (Ardour) it is running on the RT Kernel.

I also run Wine and game with WoW... Having installed the new WoW expansion WoTLK I had two annoying glitches occur... an echo (stuttering) in the audio and an issue with the mouse losing its ability to interact with various in-game windows from time to time... my efforts to find a solution to these issues drew a blank... it appeared from my googling and questions that I alone was suffering from these... I was sort of OK for the moment with the audio... it wasn't too inconvenient however the Graphics issue is a major pain causing me to have to crash the application (Alt + F4) and restart every time it glitched... and it would glitch roughly every 5-10 minutes.

So... I tried updating my Graphics driver to the 180 release in the Jaunty package... a long story short... it didn't work... no real surprise... I managed to revert to the old 169Rev driver with no problems :) HOWEVER it still hadn't handled the problem so I attempted to upgrade to Intrepid on the reasoning that I could at least get to the 177Rev driver... unfortunately all attempts at upgrade failed... I "guess" because parts of the jaunty package were still lurking (when I first tried the 180Rev install a boatload of changes were made by synaptic... including Gnome Desktop... and I started to get errors at boot of the unable to access - connection refused kind :(

SO (panicking a bit now) I "thought" of trying to go through and remove gnome-terminal-whatever (brain explosion yes I know) using Synaptic and reinstall teh earlier version in the same way that I had "undone" the Graphics driver issue... bottom line it went... along with Nautilus :( and NOW I cannot browse or open folders. Error message of "Could not open location 'file:///home/... There is no default action associated with this location. :(

No problems, thinks I, let's open the terminal and have a look... (Error: "Could not launch menu item... Failed to execute child process "gnome-terminal" (No such file or directory)" :( :(

OK Right-Click Desktop -> Open Terminal = ... waiting... waiting... still waiting... nothing :( :( :(

SO... I have STOPPED trying to fix it... which is the first sensible thing I did tonight... and I am posting this in the hope that someone somewhere can guide me in the direction of recovering my system...


tredegar 12-21-2008 10:33 AM

I don't use gnome, I hate compiz, and I don't play games, so I can't help you with your initial problems.

But I can help you get into a position where you can fix things up.

You have uninstalled your terminal, and nautilus, and you need to get them back.

There are extra (text-only) terminals on <CTRL><ALT><F1-F6>

Open one eg <CTRL><ALT><F2>

Login as yourself.

Become root:

sudo -i
Reinstall the things you removed:

apt-get install gnome-terminal
apt-get install nautilus

Go to your GUI terminal with <CTRL><ALT><F7>
Logout from (if you were logged into) your GUI and then login to your GUI
Is it fixed?
If not, go back to your root terminal with <CTRL><ALT><F2> and fix it.
Rinse, Lather, Repeat.

gsv666 12-21-2008 06:10 PM

Thanks so much tredegar I had a vague memory from my pre-reliance-on-clicking-the-mouse (windows disease) days... so initially tried <CTRL> <F2> which didn't work and <ALT> <F2> which of course brought up the RUN APPLICATION applet... which I tried "terminal" in, which of course didn't work... so I am definitely in the "know enough to be dangerous" category now.

So... anyway... logged into the terminal fine, changed to root no problems then... ran the install command for gnome terminal which came back with missing dependency gnome-control-center... so added that... which came back with a list of libraries... libvte9 libgtk2.0-0 libglade2-0 libxi6... etc all with a version number in brackets after it eg libvte9 (>= 1:0.16.9) which are needed...

So I tried to install the libraries first but it comes back that the latest versions are already installed... so then I tried to uninstall them so that I could reinstall them but that was going to uninstall a zillion packages with it so I aborted that (it is how I got into this trouble) :( I also tried "apt-get install --include dependencies" but the syntax is wrong... could you steer me in the right direction again please... :)


gsv666 12-21-2008 09:04 PM

OK so an update... things have gotten worse... I rebooted and now cannot log in graphically at all... I am posting this using the Linux Mint Live CD... so things are pretty screwed at the moment... :(

tredegar 12-22-2008 03:26 AM

I don't know what you have done to get into this mess.
Boot (from your HDD, not the CD), your graphical login isn't working, so use a <CTRL><ALT><F2> terminal
login and become root.

apt-get install gnome
If that doesn't work try uninstalling gnome first, then installing gnome.

If that doesn't work maybe start another thread "How do I re-install gnome?"

If that doesn't work maybe it is time to rescue your personal files and reinstall.

AwesomeMachine 12-22-2008 05:12 AM

Install the 'dselect' package manager. Also, try an 'apt-get update' before you do anything else.

All times are GMT -5. The time now is 12:00 PM.