LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-17-2009, 01:05 PM   #1
1337
Member
 
Registered: Apr 2009
Distribution: Slackware-12.2
Posts: 75

Rep: Reputation: 18
Bootsplash Not Working


Hello all. I just compiled a bootsplash-patched kernel 2.6.21. Everything seems to be working fine, except the bootsplash! I followed this guide...
http://n00bsys0p.wordpress.com/2009/...tsplash-howto/. When I boot up, nothing special happens. The console font is unusually large, but I boot into KDE with no problems, and no bootsplash. What could I have done wrong?
 
Old 10-07-2009, 03:58 AM   #2
xtothat
Member
 
Registered: Sep 2008
Location: Middle of Nowhere, England
Distribution: Slackware 14.1, Ubuntu 13.10
Posts: 39

Rep: Reputation: 15
Hi 1337!

I've just spotted that it's my guide you followed. Good to know people are using it ;-) Many apologies for not noticing earlier, as I just noticed the linkback sat on my WP dashboard.

In case you haven't sorted it already, here's some tips...

What it sounds like is you've got a problem with the display resolution configured in LILO.

What does your vga=0x??? line in your lilo.conf read?

There's a table here. All you need to do is change the vga= line to read vga=0x(VBE mode+200).
e.g. If you were going to use 32 bit colour depth and 1024x768 resolution, then it should read vga=0x318.

If the resolution or bit depth which you are trying to use either isn't in this table or isn't the same as the image you are trying to use, this will cause bootsplash to silently fail.

Annoyingly, in my experience, troubleshooting bootsplash is an absolute nightmare, as it pretty much logs nothing whatsoever, but persevere, as it's well worth it to have a pretty bootup :-)

Anyway, hope I've helped somewhat, much belated as it is!

X-T (aka n00bsys0p)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 bootsplash not working Orphen Fedora 1 10-15-2005 08:01 AM
I want a bootsplash, but vesafb isn't working... SonicGT Linux - Newbie 5 08-24-2005 05:29 PM
Bootsplash nearly working ! djib Debian 7 03-01-2005 08:30 PM
bootsplash OK but progressbar not working sigeberht Slackware 4 06-27-2004 07:51 AM
anyone got bootsplash working in 2.6.5 vanilla? thehundredthone Linux - Software 22 05-29-2004 02:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration