LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   boot sector and lilo collapse !!!!! URGENT URGENT URGEN !!!!! (https://www.linuxquestions.org/questions/linux-software-2/boot-sector-and-lilo-collapse-urgent-urgent-urgen-200673/)

frelihm 07-08-2004 04:38 AM

but i've tried at least 15 boot floppies, neither works. I need a boot floppy disk which will ask me for additional driver befeore boot becuase on separate disk i have driver for sata controller and hdd

frelihm 07-12-2004 08:18 AM

so, what is the parameter at boot prompt for aditional driver loading?

frelihm 07-12-2004 08:19 AM

or yet better, how do I start shell directly from boot prompt?

RagingIfrit 07-12-2004 10:30 AM

Heres what I would do, get your boot disk and load it. Then (I'm not sure if this will work with debian) choose Upgrade Your Current Installation and just follow through. This may be only Fedora Core 2, but if it works in Debian, then it should preserve your information and reinstall/fix your bootloader at the same time. Good luck!

frelihm 07-12-2004 02:57 PM

i do not have any options availabe, just lilo main screen, and when i load the boot disk it says: kernel panic, cannot mount root on 08:01 (/dev/sda1), since there is no driver in memory to handle SATA hdd

frelihm 07-13-2004 03:37 PM

I'VE DONE IT :) with bootable cd (debian) :) problem solved

manichandra 12-02-2009 10:21 AM

Quote:

Originally Posted by b0uncer (Post 1025729)
hm...what if you did a new bootdisk, but made it so that it has the driver in it? wouldn't that be the simplest way... (or actually, I dont' know about the simplicity..but) the problem of course is that you need a working linux to do this..

EDIT: sorry I can't help with lilo. it's just that I haven't used lilo for a long time now, not after I installed grub..


check you hdd that might having problem and might be you din't create lilo properly and always create boot disk tha can sve your data data is important ?


All times are GMT -5. The time now is 05:17 PM.