-   Linux - Software (
-   -   Boot freezes at "Starting HAL daemon" after Kernel recompile (

DiBosco 04-13-2007 09:32 AM

Boot freezes at "Starting HAL daemon" after Kernel recompile
I have tried recompiling the kernel on Mandriva 2007.0 to fix a bug where by a touchpad isn't recognised. Although it seems to compile OK, when I now boot and choose the new image, the boot freezes at this line:

Starting HAL daemon [ OK ]

The only error I can see before that is:

Starting wltool: [Failed]

I've tried a recompile about five times now and nothing makes any difference it seems. Anyone know why that might be? Or can suggest a method of tracking this down? Please ask if any other information would help track it down. I'm in over my head really and am not sure where to start!

I have searched high and low on the web and found other mentions of HAL daemon failing, but not freezing when it says it's OK!

Many thanks.

weibullguy 04-14-2007 02:03 AM

Wonder if the service that tries to start after HAL is hanging up, not HAL itself?

Look in a file called /etc/inittab for a line (probably one of the first) like this

That number tells you what runlevel you boot into. Then look in the directory /etc/rc.d/rc#.d (rc3.d in this example). You should see a symlink named S##haldaemon. Alphanumerically after that would be the next service to start. For example, mine is S20haldaemon and the next one is S25cups.

DiBosco 04-14-2007 05:53 AM

Thanks for the suggestions Arow. Just before I gave in to sleep last night I made a lot of progress on this and found your reply when I woke up this morning.

I found another post on here for a vaguely similar issue with Fedora; that suggested looking at boot levels. After playing about with it I found that I could boot to level two and then startx. :confused: This then ran KDE, and my kernel mod had solved my touchpad issue.

I then rebooted and did interactive boot (I had completely forgotten this is possible, it's so long since I needed to do that). When it got to the touchpad part and asked if I wanted to start it, when I said yes, it went and installed some drivers from the installation DVD.

It boots happily now, which I guess is the main thing!

All times are GMT -5. The time now is 10:01 AM.