-   Linux - Software (
-   -   Boot Error + GRUB + Rescue Mode (

najeebsyed2 10-31-2007 12:47 PM

Boot Error + GRUB + Rescue Mode
Hello all,
I have just cloned a smaller disk onto a larger disk with a substantial amount of free space. This is a Linux FC 3 box. I used GRUB as the boot loader.

However, when I try to boot for the cloned disk, there is no OS found.

When I use the Fedora Core's Rescue CD in rescue mode it says " You don't have any Linux partitions. Press return to get a shell. They system will reboot automatically when you exit from the shell."

It looks like it is not detecting the previously installed OS or it is not mounting it to /mnt/sysimage directory. I have tried to boot of a Knoppix CD and use the fdisk command and it shows me the linux partitions. I also used the cfdisk command and saw that the bootable flag is set on my boot partition.

At this point I cannot do anything. Please help !!!

thank you all very much in advance.

mckheuneedshelp 10-31-2007 12:55 PM

when i put fedora core on my ps3 i had to rewrite the disk 5 times before it worked , ... but maybe thats just the ps3 ... ;)

najeebsyed2 10-31-2007 01:21 PM

Hello all,
This is the error I get. This might shed some light on the issue:

Ext3-FS: unable to read superblock
mount: error 22 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount/intrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init.

I hope this out put helps. Thank you for all your help in advance.

bigrigdriver 10-31-2007 02:22 PM


I have just cloned a smaller disk onto a larger disk
Tell us more about how you did it. Maybe just an error in procedure?

najeebsyed2 10-31-2007 03:04 PM

I used Acronis True Image Linux version to clone the disk. I verified the procedure by viewing the cloned hard drive via the hardware manager. It showed the cloned Disk and all the partitions on it. But it just won't boot.

Initially it wouldn't boot but after a reinstalled GRUB using the a knoppix CD it read the OS but failed to mount the file system. I have been trying to find answers all day today. It is becomming very very painful.

saikee 10-31-2007 03:11 PM

Linux's terminal command using dd is much more reliable.

Fedora C4 also likes to address the hard disk partition by a lablel so the original should be removed, otherwise two identical labels may cause confusion.

najeebsyed2 10-31-2007 03:14 PM

Well, thanks for that, but we are trying to use the Acronis Software in a test enviornment so that we can backup our productions boxes. I am not sure about the Labels...sorry I am would i ID then then remove identical lables?

najeebsyed2 10-31-2007 03:29 PM

I feel sad.....

saikee 10-31-2007 04:31 PM

If you are testing Acronis Linux version then you need something to compare with, right?

So use dd and see if it works as suggested by one line of command

dd if=/dev/sdx of=/dev/sdy bs=32256
where sdx is the smaller source disk and sdy is the bigger target disk.

If this boots while Acronis doesn't then there is no much point to invent Acronis in Linux to beat a terminal command that can carry out the same task but faster, easier and simpler.

Seems to me (based on personal experience never find dd fail to clone any or all Dos, Windows, Linux, BSD and Solaris systems)

Acronis in Linux = to invent a square wheel.

Round wheel already in use = dd command available in every Linux , BSD and Solaris.

najeebsyed2 11-01-2007 09:08 AM

Thanks for the alternative suggestion. I will give it a shot.

All times are GMT -5. The time now is 11:46 AM.