LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Bluetooth suddenly stopped working (https://www.linuxquestions.org/questions/linux-software-2/bluetooth-suddenly-stopped-working-890739/)

aurora72 07-09-2011 03:31 AM

Bluetooth suddenly stopped working
 
hello

I'm using a Lenovo 3000 Laptop with Linux/Ubuntu 10.10 and so far no problems with Bluetooth.

But lately the BT suddenly stopped working throughly, even the Bluetooth New Device Setup doesn't work and it can not be the BT devices, mouse, BT headset all not working it's the Laptop's BT which is not working.

I've tried /etc/init.d/bluetooth restart and still the same.

What could be wrong, what should I do, thanks

Peacedog 07-09-2011 07:17 AM

Hi aurora72, Welcome to LQ. What does hciconfig say about the device? What kernel version are you on? Any recent updates?

Code:

# hciconfig
$ uname -r

Good luck. ;-)

aurora72 07-09-2011 02:33 PM

Hello and thanks.
hciconfig output:
Code:

hci0:        Type: BR/EDR  Bus: USB
        BD Address: 00:22:69:FA:3B:1B  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING PSCAN
        RX bytes:1026 acl:0 sco:0 events:36 errors:0
        TX bytes:1594 acl:0 sco:0 commands:36 errors:0

uname -r output:
Code:

2.6.35-28-generic
This laptop 's got several kernel versions appearing on startup. That's so since I updated the Nvidia GPU's driver suit.

I don't think this problem occured after an update or anything. I don't remember making any basic update in between. I might have just installed some application such as Quicktime player, though.

UPDATE: I solved the problem after this: I have removed those mouse and the headset I'm talking about in Bluetooth Preferences section and run Setup New Device for them again and it worked, finally!

Thanks.

Peacedog 07-09-2011 03:27 PM

Glad you got it sorted.

Good luck. ;-)


All times are GMT -5. The time now is 11:10 PM.