LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-24-2016, 05:54 PM   #1
damico
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Rep: Reputation: Disabled
Bluetooth Speaker doesn't show in sound settings


Hi,

I recently installed Kali Linux. Then, I paired my bluetooth speaker (harman/kardon Onyx Studio) to the notebook and could set the default sound to the speaker. The day after, the Bluetooth said it was connected, but the speaker was not showing any more at sound settings.

I tried many things, and something that I tried messed with my bluetooth, and the device was not working anymore. So I decided to reinstall Kali and now the Bluetooth is working, but the speaker still does not show in soun settings, even the Bluetooth section says it is paired.

I also have windows in this notebook, and through windows the Speaker works.

Some information:

Code:
root@ilak:~# uname -a
Linux ilak 4.4.0-kali1-amd64 #1 SMP Debian 4.4.2-3kali1 (2016-02-23) x86_64 GNU/Linux
Code:
root@ilak:~# hciconfig
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 00:27:13:BD:5B:74  ACL MTU: 1021:8  SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN INQUIRY 
	RX bytes:17442 acl:181 sco:0 events:2015 errors:0
	TX bytes:856081 acl:1159 sco:0 commands:739 errors:0
Code:
root@ilak:~# lsusb
Bus 004 Device 005: ID 03f0:231d Hewlett-Packard Broadcom 2070 Bluetooth Combo
Bus 004 Device 004: ID 04f2:b230 Chicony Electronics Co., Ltd Integrated HP HD Webcam
Bus 004 Device 003: ID 14cd:121c Super Top microSD card reader
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 4971:1024 SimpleTech 
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 138a:003c Validity Sensors, Inc. VFS471 Fingerprint Reader
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Code:
root@ilak:~# lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]
24:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller (rev 30)
24:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
24:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
25:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
26:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
root@ilak:~#
Code:
root@ilak:~# dmesg | grep Blue
[    4.977847] Bluetooth: Core ver 2.21
[    4.977866] Bluetooth: HCI device and connection manager initialized
[    4.977870] Bluetooth: HCI socket layer initialized
[    4.977874] Bluetooth: L2CAP socket layer initialized
[    4.977884] Bluetooth: SCO socket layer initialized
[    8.037840] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.037843] Bluetooth: BNEP filters: protocol multicast
[    8.037847] Bluetooth: BNEP socket layer initialized
[    8.051888] Bluetooth: RFCOMM TTY layer initialized
[    8.051898] Bluetooth: RFCOMM socket layer initialized
[    8.051902] Bluetooth: RFCOMM ver 1.11
Code:
root@ilak:~# dmesg | tail
[   14.756043] radeon 0000:01:00.0: evergreen_surface_check_2d:281 texture pitch 1600 invalid must be aligned with 128
[   14.756047] radeon 0000:01:00.0: evergreen_cs_track_validate_texture:830 texture invalid 0x18fc31c1 0x40000383 0x060a0000 0x00000000 0x80000000 0x800204da
[   14.756065] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !
[   15.238960] fuse init (API version 7.23)
[   17.603963] FAT-fs (sdc1): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[   17.614028] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[  352.915009] input: 0C:A6:94:B5:EF:75 as /devices/virtual/input/input23
[  375.931185] input: 0C:A6:94:B5:EF:75 as /devices/virtual/input/input24
[ 7037.838561] input: 0C:A6:94:B5:EF:75 as /devices/virtual/input/input25
[ 7128.488153] input: 0C:A6:94:B5:EF:75 as /devices/virtual/input/input26
Code:
root@ilak:~# bluetoothctl
[NEW] Controller 00:27:13:BD:5B:74 ilak [default]
[NEW] Device 0C:A6:94:B5:EF:75 HK Onyx Studio
[NEW] Device 78:1F:DB:1D:D7:10 E2220
[bluetooth]# connect 0C:A6:94:B5:EF:75
Attempting to connect to 0C:A6:94:B5:EF:75
Failed to connect: org.bluez.Error.Failed
[bluetooth]# connect 0C:A6:94:B5:EF:75
Attempting to connect to 0C:A6:94:B5:EF:75
Failed to connect: org.bluez.Error.Failed
[CHG] Device 0C:A6:94:B5:EF:75 Connected: yes
[CHG] Device 0C:A6:94:B5:EF:75 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 0C:A6:94:B5:EF:75 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 0C:A6:94:B5:EF:75 UUIDs: 0000110d-0000-1000-8000-00805f9b34fb
[CHG] Device 0C:A6:94:B5:EF:75 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[HK Onyx Studio]# info 0C:A6:94:B5:EF:75
Device 0C:A6:94:B5:EF:75
	Name: HK Onyx Studio
	Alias: HK Onyx Studio
	Class: 0x240414
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	RSSI: -33
[HK Onyx Studio]#
I apreciate any help

Speaker connected

Sound Settings

Thanks in advance.
 
Old 02-25-2016, 05:35 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,480

Rep: Reputation: Disabled
Hi

I noticed no-one has replied after one day and I don't have BT speakers so can only offer limited help.

one....if you have future bluetooth problems pls don't re-install the system....just unpair your device and start again.

two ....the image does not show the pavucontrol for the last tab....I was expecting to see BT speakers come an option there...without an image are you confirming its not an option?

three...notebooks sometimes have a button or a slider switch that can instantly activate/de-activate wifi/cellular and BT.
Is there a led showing BT is working for notebook side?

Do you have another BT device such as an android or smart phone you can pair?
 
Old 03-01-2016, 02:23 PM   #3
damico
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by aus9 View Post
Hi

I noticed no-one has replied after one day and I don't have BT speakers so can only offer limited help.

one....if you have future bluetooth problems pls don't re-install the system....just unpair your device and start again.

two ....the image does not show the pavucontrol for the last tab....I was expecting to see BT speakers come an option there...without an image are you confirming its not an option?

three...notebooks sometimes have a button or a slider switch that can instantly activate/de-activate wifi/cellular and BT.
Is there a led showing BT is working for notebook side?

Do you have another BT device such as an android or smart phone you can pair?
Hi Aus,

Sorry for the late answer.
  1. I dont have Pavucontrol. Should I install?
  2. The button of bluetooth is the same of wireless and it is on. No leds.
  3. Before I formatted the notebook, I could find my mobile Android.
  4. Now, the behavior of bluetooth changed. I can't find any devices, nor the devices can find me. I can't delete the device paired before, and the speaker can't connect anymore.
 
Old 03-01-2016, 08:09 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,244
Blog Entries: 27

Rep: Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337Reputation: 5337
Yes, you should get pavucontrol. It's the Pulse Audio mixer and generally shows more controls than simple volume control applications.

Beyond that, I don't know enough about bluetooth to make any recommendations.
 
Old 03-02-2016, 01:30 AM   #5
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,480

Rep: Reputation: Disabled
Hi

Quote:
The button of bluetooth is the same of wireless and it is on.
thats ok same as my old dell...pls double check that bios settings still have BT enabled pls.

2) yes pls install pavucontrol as frankbell also recommends.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound from Terminal not playing through bluetooth speaker abourke Linux - Newbie 1 02-09-2016 03:08 AM
Sound not coming out of bluetooth speaker baronobeefdip Linux - Hardware 4 11-19-2014 02:12 AM
why doesn't HDMI only show picture and not sound? nickswitch Linux - Newbie 4 03-01-2011 08:55 PM
Problem with MythTV: Video doesn't always show up, sound works but... ghost_zero Linux - Software 1 09-20-2004 03:56 PM
[sound] Alsa works, speaker doesn't BlackCell Linux - General 3 11-12-2003 04:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration