LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-01-2017, 09:53 PM   #1
Sol33t303
Member
 
Registered: Jul 2017
Posts: 103

Rep: Reputation: Disabled
Blueman can detect devices but won't pair to them


Recently I have been trying to pair my DualShock 4 controller to use with my PS2 emulator, but when I try to pair my controller, it says "Pairing failed", the controller is in paring mode so thats not the issue, while trying to fix this I installed KDE's bluetooth manager BlueDevil, since then when I log in to my Linux partition it shows me this message:
Code:
g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.GLib.Error: Traceback (most recent call last):
  File "/usr/lib64/python3.6/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3.6/site-packages/blueman/main/DbusService.py", line 38, in wrapper
    return method(*args[1:], **kwargs)
  File "/usr/lib/python3.6/site-packages/blueman/plugins/mechanism/Network.py", line 56, in ReloadNetwork
    self.confirm_authorization(caller, "org.blueman.network.setup")
  File "/usr/libexec/blueman-mechanism", line 166, in confirm_authorization
    action_id, {}, 1, "")
  File "/usr/lib64/python3.6/site-packages/gi/overrides/Gio.py", line 172, in __call__
    None)
GLib.GError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.70" (uid=0 pid=2276 comm="python3 /usr/libexec/blueman-mechanism " label="system_u:system_r:blueman_t:s0") interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" error name="(unset)" requested_reply="0" destination=":1.9" (uid=997 pid=956 comm="/usr/lib/polkit-1/polkitd --no-debug " label="system_u:system_r:policykit_t:s0") (9)
 (36)
Here is some of my system info using screenfetch:
Code:
           /:-------------:\          Sol33t303@Altair
        :-------------------::        OS: Fedora 26 TwentySix
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 4.12.10-300.vanilla.knurd.1.fc26.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 10m
   :-----------sMMMMNMNMP.    ---:    Packages: 2746
  :-----------:MMMdP-------    ---\   Shell: bash 4.4.12
 ,------------:MMMd--------    ---:   Resolution: 2048x1152
 :------------:MMMd-------    .---:   DE: GNOME 
 :----    oNMMMMMMMMMNho     .----:   WM: GNOME Shell
 :--     .+shhhMMMmhhy++   .------/   WM Theme: Adwaita
 :-    -------:MMMd--------------:    GTK Theme: Adwaita [GTK2/3]
 :-   --------/MMMd-------------;     Icon Theme: Adwaita
 :-    ------/hMMMy------------:      Font: Cantarell 11
 :-- :dMNdhhdNMMNo------------;       CPU: Intel Core i7-6700K @ 8x 4.2GHz [27.8C]
 :---:sdNMMMMNds:------------:        GPU: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
 :------:://:-------------::          RAM: 3472MiB / 7861MiB
 :---------------------://
 
Old 09-02-2017, 09:52 AM   #2
archh666
LQ Newbie
 
Registered: Aug 2017
Distribution: Linuxarch
Posts: 11

Rep: Reputation: Disabled
I've seen this "bug" before, it was reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1441920 and here: https://github.com/blueman-project/blueman/issues/711, Though it seems to don't have a clear solution.
 
Old 09-02-2017, 10:14 AM   #3
Sol33t303
Member
 
Registered: Jul 2017
Posts: 103

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by archh666 View Post
I've seen this "bug" before, it was reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1441920 and here: https://github.com/blueman-project/blueman/issues/711, Though it seems to don't have a clear solution.
Hopefully, when Fedora 27 releases on the 24th this bug will be addressed, I've since gotten my controller to work via USB from when I posted the question so I don't really need to fix it for now so I guess I'll wait until Fedora 27 to see if that fixes it.
 
1 members found this post helpful.
Old 09-02-2017, 11:32 AM   #4
archh666
LQ Newbie
 
Registered: Aug 2017
Distribution: Linuxarch
Posts: 11

Rep: Reputation: Disabled
Quote:
Originally Posted by Sol33t303 View Post
Hopefully, when Fedora 27 releases on the 24th this bug will be addressed, I've since gotten my controller to work via USB from when I posted the question so I don't really need to fix it for now so I guess I'll wait until Fedora 27 to see if that fixes it.
All right so, let's hope they fix it!
Have a nice day
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Not possibile to search for devices in Blueman-mangaer, bluetoothd is running glupa4e Slackware 9 11-23-2017 09:49 PM
Bluetooth can pair devices but there is no connectivity bobsie Slackware 9 11-11-2013 03:42 AM
Blueman won't mount device Ook Slackware 7 07-02-2012 07:11 PM
USB won't Auto Detect for Plug-n-Play Devices The-Riot Linux - Newbie 3 11-28-2009 04:23 PM
How to pair bluetooth devices? JET-33 Linux - Software 1 08-24-2007 11:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration