LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-25-2004, 12:24 AM   #1
matttah
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Rep: Reputation: 0
Blender and crashing when going to 3d views


I can load it up fine, and draw but when i go to do a 3d view(in the same window, just look around the object, by pressing "d") the comp freezes, when i reboot i checked the logs and this is the problem.
atkbd.c: Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying access hardware directly.

Anyone know how to fix this? I really wanna do the rendering in linux rather than booting into windows for it. Thanks

PC Info
Using ati x800 pci-express se, xfree, and ati drivers-on gentoo.
Daum

Last edited by matttah; 11-25-2004 at 01:12 PM.
 
Old 11-25-2004, 12:39 PM   #2
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
You mean "Blender" right...???
Pressing D brings up the draw mode. Crashing at this point could indicate that your OpenGL drivers are screwed. (but in that case blender should'nt have started at all) Ah.. anyway.. try running glxgears.. if that runs then GL is fine.. there might be some other issue.
 
Old 11-25-2004, 01:11 PM   #3
matttah
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
doh yeha ment blender=)

glx gears=23873 frames in 5.0 seconds = 4774.600 FPS

Works fine.

What i find weird is that i can hit d sometimes..but just not when i do this tutorial...
http://www.digitalhermit.com/linux/ray_tracing/blender/
On the step where you hit d. If i hit d right when it opens its fine.

Daum

Last edited by matttah; 11-25-2004 at 01:13 PM.
 
Old 11-26-2004, 02:15 PM   #4
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
Hmm.. I cant see why the tutorial should cause anything.. where exactly in the tutorial are you when you crash.
Which version of Blender are you using?
 
Old 11-26-2004, 02:27 PM   #5
matttah
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
updated to 2.35 last night. Now it works much better but sometimes if i do an action too quick(undo a bunch of times) or when i first boot up, the program decides if its gonna crash and stall the system. If after one minute i can use it, it is good until i do something like hit undo or subdivide a ton of times. then it gives the same error in the var log messsages.
Daum
 
Old 11-27-2004, 06:21 AM   #6
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
May be I am wrong.. but I think you need more RAM..
 
Old 11-27-2004, 10:30 AM   #7
matttah
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
1 gig isn't enough? at 533mhz ddr2....p4 w/ht 800fsb at 3gig hrtz.
Daum
 
Old 11-27-2004, 11:46 AM   #8
proudclod
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 381

Rep: Reputation: 30
Are you using xorg 6.8 or 6.7?

As the ATI drivers have serious problems with doing 3d under 6.8.

EDIT: Never mind, just read the other replies, seems that isn't the problem.
 
Old 11-27-2004, 11:54 AM   #9
matttah
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
using XFree86 Version 4.3.0.1.
When i installed gentoo, xorg wasn't support ati pci express cards....and xfree's general driver worked..then ati-drivers started to work for pci express.
Do i need to set the amount of memory blender has to use maybe?
I would think it'd just keep taking as much as it'd like.
Daum
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 3.3.2 : titlebar color blending stl1859 Linux - Software 2 01-09-2005 12:08 AM
opengl -> Blending hylke Programming 4 08-10-2004 08:14 AM
Blending Sci Fi series? carrja99 General 0 03-16-2003 01:11 PM
windowmaker alpha blending raven Linux - Software 0 12-12-2002 01:58 PM
Blending of Terminals into Desktop Background, How to? Kinshin Linux - General 5 03-31-2002 10:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration