-   Linux - Software (
-   -   Blender won't start (

metalx1000 12-21-2007 11:00 AM

Blender won't start
I'm running PCLinuxOS 2007 Stable and when I updated a little while back to Blender 2.45 I started having problems. First when I went to camera view the view was blackened. Then a week or so ago blender would just crash when I tried to start it. So I uninstalled and reinstalled it using Synaptic Package Manager. Still will crash on load.

If I start it in Konsole I get this massage

Compiled with Python version 2.4.3.
Checking for installed Python... got it!
libGL warning: 3D driver claims to not support visual 0x4b
/usr/bin/blender: line 61: 10485 Segmentation fault      ${BLENDER_LIBDIR}/blender/blender.sse "$@"

It worked before the upgrade and it still works on my laptop that is running the same OS and Version of Blender.

Thanks for and Help

matthewg42 12-22-2007 09:42 AM

Blender uses accelerated 3d OpenGL graphics to draw the user interface. Your video card must support OpenGL, and your video driver too.

What graphics card do you have in the computer?

What graphics driver is installed?

You can find some information about the driver which is being used with this command entered into a konsole terminal:

glxinfo |grep -i vendor
Please pasted the results into this thread.

metalx1000 12-23-2007 04:27 PM

I'm not at my desktop now, and I'll run that command when I get home. But, Blender was working on that computer before. I had been using it for almost 2 years.

matthewg42 12-24-2007 12:43 AM

I guess something must have changed, else it would still be working.

I don't know that it might be, but I can suggest some methods by which you might find out what is going on. No promises of course - maybe it's something I don't know about.

My first theory is that there was an update to your kernel or video driver which has broken accelerated OpenGL. This is at least partly consistent with the message you described.

Lets see if we can verify the idea, or show that it is not true.

metalx1000 12-25-2007 09:11 AM

I did do a "mark all upgrades" in synaptic not to along ago. Don't know if that caused it and if so what could I do to fix it?

Merry Christmas

All times are GMT -5. The time now is 03:05 PM.