-   Linux - Software (
-   -   Blender - how do I compile it? (

ButterflyMelissa 11-14-2011 11:41 AM

Blender - how do I compile it?
Hey gang!

Okay, so my Blender (sice some time now) crashes with a segmentation fault. Pretty annoyning, but what's there to do?
So, I've been pondering and why not compile it from source? That way, the compiler should be able to tell me what's missing in the system?
But...there is this SCons thing that does'nt want to deliver. So, anyone been successfull in compiling Blender3D?

Please share...



colucix 11-14-2011 12:27 PM

I compiled blender 2.5 on a OpenSuSE box x86_64 some time ago. I've not that machine at hand right now but I followed guidelines here and it worked flawlessly. The scons stuff is embedded in the source code, so you shouldn't worry about installing it.

jthill 11-14-2011 12:41 PM

Assuming you've tested moving your ~/.blender out of the way to eliminate config problems, I suspect a display driver problem, not something a recompile will fix.

ButterflyMelissa 11-14-2011 01:01 PM

@colucix : thanks, now I know how to use svn :) - I was compiling, as I looked at jthill's tip. But, no luck, I moved (cut-n-paste) the .blender away, but stull no luck. Of course, blender does'nt rebuild its config I assume the config is (now) stored elsewhere...
@jtill : stopped the recompile - there were no warnings ans my box meet all the requirements. Unless (of course, that is a stupid remark, as Blender worked all the time) something has changed in Vlender that it has troubles in XFCE...

Hmmm...luckily Blender is'nt a need-package for would have been all-round-panic if this happened on Eclipse :D

jthill 11-14-2011 01:18 PM

Should have mentioned I've got a box with an old ATI R300-based GPU, blender started glitching badly and/or segfaulting around 2.56 or something on that.

ButterflyMelissa 11-14-2011 01:33 PM


around 2.56 or something on that
My observation excactly! But, I installed (downgraded - Arch has a downgrade script) 2.47 and - bam, no luck, still the same segmentation fault...
So, the itch is deeper...

ButterflyMelissa 11-16-2011 03:00 PM

So...just a quick thought, before I turn in - can Blender be started from the console? Yes. Can it be started with parameters? Dunnow...does any of you know?

Please share, thanks. This is somewhat annoying...not being able to figure this out :/


ButterflyMelissa 07-06-2014 12:05 PM


Blender can (as all things Linux) be fired off from the console, in fact, it's the prefered wa to fire up a program that ill-behaves anyway. THE solution: use "downgrade" (repo of Arch) or...get an older version from Blender (archives) and unzip it in your user space...start THAT one up:


cd to/the/blenderfolder
the ./ is crucial, as ommitting it will start up the default Blender (applies to anything on the system too, is'nt Linux sweet?)

Just me sharing with the rest of the world, and doing so in restitution...I should have "cleaned" up long ago...


All times are GMT -5. The time now is 08:27 PM.