LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-24-2003, 10:09 AM   #1
phishintrip
Member
 
Registered: Jun 2003
Distribution: Slack9, Red Hat 8.1
Posts: 117

Rep: Reputation: 15
blackbox noob ?


i am running slack9 on a slow ass laptop and so far have been using kde for my xwindows enviroment. I heard blackbox would run a lot faster so i got the file untar'ed ./configure, make, make install. Problem is how do i tell the xserver to start up using blackbox instead of kde?

I know this is a noob ? but i am still a noob so. I figure i can figure out how to change all the settings and menus once i see what the default settings look like.
 
Old 07-24-2003, 10:40 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I kind of goofed up my Slack wm stuff at first so I don't know if the file would get created or if you have to do it. (I may still be goofing it up.) But create an xinitrc.blackbox in /etc/X11/xinit if it isn't there and then run 'xwmconfig' and you'll be able to choose between various managers including blackbox. Or just create your own ~/.xinitrc, I guess. The first option would be better. That'll do the ~/.xinitrc creating for you.

-- Try running 'xwmconfig' first, of course, just to see if it's in the list.

Last edited by slakmagik; 07-24-2003 at 10:42 AM.
 
Old 07-24-2003, 01:08 PM   #3
phishintrip
Member
 
Registered: Jun 2003
Distribution: Slack9, Red Hat 8.1
Posts: 117

Original Poster
Rep: Reputation: 15
so i ended up just adding blackbox instead of startkde at the end of my xinitrc file. Now it starts and i guess i am in blackbox. It comes up with two xterm windows and one named bash. There is no background or anything. I am installing bbconf so i am hoping that will help.
My problem right now is that i cant see the whole screen only like the top left 2/3 or so. Anyone know how to fix this or should i just read anout bbconf when it finishes installing?
 
Old 07-24-2003, 01:31 PM   #4
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Um. If there's another terminal and a clock, I'd say you were in twm. Blackbox is minimal but you should get a bg image and right-click menu and a toolbar and so on.

I have no idea why your screen would be weird with blackbox if it was good in kde unless you reconfigured X or something. Blackbox doesn't control display, as such, but only windows and its internals.

Course, it's been awhile since I used blackbox - I use flux now.
 
Old 07-24-2003, 01:49 PM   #5
phishintrip
Member
 
Registered: Jun 2003
Distribution: Slack9, Red Hat 8.1
Posts: 117

Original Poster
Rep: Reputation: 15
yes twm
thats exactly what im in so how do i go from there to blackbox?
i know i am in twm b/c when i click out on the screen somewhere it says twm and gives me options like resize, kill, etc.
 
Old 07-24-2003, 01:50 PM   #6
phishintrip
Member
 
Registered: Jun 2003
Distribution: Slack9, Red Hat 8.1
Posts: 117

Original Poster
Rep: Reputation: 15
what's twm?
 
Old 07-24-2003, 02:01 PM   #7
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
twm's -- I think it's "Tom's Window Manager"? I forget. It's like the original X window manager. It actually can be customized to be almost usable but... well, I wouldn't. *g*

Well, like I say, try running xwmconfig - if /etc/X11/xinit/xinitrc.blackbox doesn't exist or isn't created by it, try copying and editing one of the lightweight wm files in that directory - change the name and the wm it starts. Then run xwmconfig again and select it.
 
Old 07-24-2003, 02:12 PM   #8
phishintrip
Member
 
Registered: Jun 2003
Distribution: Slack9, Red Hat 8.1
Posts: 117

Original Poster
Rep: Reputation: 15
thanks, i got into it. First, i ran xwmconfig and selected my xinitrc.kde, then i edited that file to read blackbox instead of startkde at the end. I tried it and it worked so in order for it to be right. I am going back now to copy xinitrc.kde to xinitrc.blackbox, then i will run xwmconfig again and select the xinitrc.blackbox, then go edit my xinitrc.kde back to startkde.
Thankyou again for the help!!!!
 
Old 07-24-2003, 02:27 PM   #9
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Glad you got it going.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
noob with a noob question phoonerorlater Linux - Newbie 2 09-29-2004 04:43 PM
3 Noob Quetions From A Noob DaveyB Slackware 20 08-11-2004 09:00 PM
BlackBox look shoki_neu Linux - Software 0 05-21-2004 05:23 AM
Firewall help (noob really really huge noob) ProtoformX Linux - Networking 1 03-29-2004 01:19 AM
Complete noob question from a noob noob_hampster Linux - Software 2 09-04-2003 01:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration