-   Linux - Software (
-   -   Blackbox and .xinitrc problem (

firefly2442 10-23-2003 08:52 PM

Blackbox and .xinitrc problem
Hi. I just installed Blackbox, everything went smoothly from the install. But now I have to configure it so that it will run when I type "startx" at the command line. I need to edit ".xinitrc" but I cannot find the file. I am running Red Hat 9. Thank you. :)

edit: I also moved the extracted files from the source to /usr/local/bin/
I hope this is correct.

edit2:I created a file called ".xinitrc" and put it in my /root/ directory. Added the line "exec blackbox" but for some reason when I run "startx" it cannot find it and it errors out. Could it be blackbox was not installed correctly? I will go and try to find an .rpm, maybe that will work better.

absolut_ray 10-23-2003 09:40 PM

i know this sounds stupid and ameteur-ish, but did you run
"make install" ?
and not just make when you compiled it?

akaBeaVis 10-23-2003 09:41 PM

To test it, instead of startx, type xinit, X will start and usually a default "login" console with it, then type blackbox & in that console, you'll have to move your cursor into it for it to get focus and let you type. If it works, then your blackbox install is ok, otherwise not.

firefly2442 10-23-2003 09:57 PM

Wow, it works great. I just have to go about getting to it another way hehe. Well, I'm running it right now. It's nice. Very clean and light. Not as heavy as KDE or GNOME. Stupid question but is there any sort of file manager or way to get at files other than the command line? Is Blackbox customizable? Thanks.

akaBeaVis 10-23-2003 11:00 PM

Don't know anything about Blackbox, I run icewm the way I described to you, and I like it enough to stick with it. If you start your X session with xinit, you can place things in the /home/.xinitrc dir and they will work (they do for me).

slakmagik 10-23-2003 11:52 PM

The *boxes don't come with their own apps, but you can use general apps and even Gnome and KDE apps. But if you like 'clean and light', there's always mc in an xterm or something like gentoo (not the distro). There's also at least three active threads in the past 24 hours about file managers so you might check those out, too. :)

I should check out the blackbox site - I have no idea what they've been up to. Fluxbox is a fork of blackbox that stole me away from the original.

And - just checking - you know .xinitrc is hidden, right? 'ls -A' or 'ls -a' will show it. But then RH does stuff weird so I don't know if editing that is all it would take or not - it's all it should take, anyway. :)

Oh, yeah - customizable. AFAIR, there's a ~/.blackbox directory with a few files and you can customize quite a bit with them. Seems like the man page is pretty good about describing them. The mechanics are somewhat customizable and you can make it *look* like anything you want, basically.

-- Dunno how I missed your edit. That was a long time ago. .xintirc should be in your home directory, which shouldn't be /root. *g* And as long as blackbox is on your path, the exec line should do it. Have you already gotten past that part? When you say it works great, I guess you have, but you didn't say.

All times are GMT -5. The time now is 06:14 PM.