-   Linux - Software (
-   -   Black Screen after Boot (

HitmanIP7 05-13-2003 12:39 PM

Black Screen after Boot
I recently installed Red Hat 8.0, and the install went fine (apart from a problem with the Grub bootloader, so I had to do a re-install and choose Lilo instead. Which works fine)

The problem is that Linux boots, but when it finishes and is about to go to the graphical login, I just get a black screen.

I had the same problem when I tried to use the graphical installer as well. I did try to get the graphical install working by trying 'linux lowres', 'linux resolution=800x600', etc, but none worked.

How can I fix this?

yowwww 05-13-2003 12:44 PM

do you have more than one video card? ie - one onboard and one agp/pci? you would need to specify which one to use during the install, also check to make sure the sync rates of your monitor are correct.

HitmanIP7 05-13-2003 12:51 PM

I have onboard graphics only.

Im using the ASUS A7N266-VM motherboard, which has onboard GeForce 2 graphics.

HitmanIP7 05-13-2003 05:11 PM

Any suggestions?

Tinkster 05-13-2003 06:22 PM


Originally posted by HitmanIP7
Any suggestions?
Just questions ... does the box die then?
Or can you get to a text console by
pressing Ctrl-Alt-F1 (or 2,3,4... :})?


HitmanIP7 05-14-2003 12:48 PM

I havent tried that yet. I will give it a try tonight.

masand 05-14-2003 01:05 PM

try ctrl-alt_(f1 f2 )
then at the prompt login and try "startx"
or "Xconfigurator"( i am not sure abt. the correct command of Xconfigurator, i think this the one with X in caps)

HitmanIP7 05-14-2003 01:15 PM

Oaky, thanks.

I will give it a try.

HitmanIP7 05-14-2003 02:34 PM

I tried pressing Ctrl-Alt-F1 (F2, F3 and F4) when I got the black screen. But I didn't get anything.

I can press Ctrl-X at startup to get to a prompt saying 'boot:', but the only command that works there is 'Linux', which boots linux.

david_ross 05-14-2003 02:38 PM

1) Add " 3" to your kernel arguments then when you boot you should be in CLI mode.
2) Login as root
3) Run "redhat-config-xfree86" to configure your hardware
4) Test your settings by running "Xtest", you will get a message on your screen asking if it has worked. If it hasn' then just leave it for 15 seconds and it will exit automatically. You can then go back to step 3 and reconfigure your hardware.

HitmanIP7 05-14-2003 02:54 PM

Thanks, but I am a bit of a Linux newbie. :) Sorry.

How do I add " 3" to my kernel arguments?

Will I need to boot into rescue mode to do this? and what is the command to do it?

I do get the last few bits though!

david_ross 05-14-2003 03:35 PM

At the bootloader stage there should be an option to edit the proccess. You press "e" in grub - I'm not sure about LILO. Then look for the line starting with kernel and add " 3" (no quotes) to the end of that line.

HitmanIP7 05-14-2003 04:40 PM

Okay, I will give it a try.

davecs 05-14-2003 04:58 PM

I have the same motherboard as you and I do not have this problem (I use Mandrake 9.1)

Have you downloaded and installed the nVidia driver?

Also: I did have a problem with my on-board graphics due to a timing problem. If you have Windows, can you use Win to put your monitor into the desired resolution, then press the button(s) on the front of your monitor to find out the Vertical Refresh and Horizontal Sync.

Then as root, edit your XF86Config-4 file (if it is not there, use XF86Config), and ensure that the range given in the lines VSync and HSync or similar cover your monitor's timings. I did this and my picture went from a complete disaster (so much shaking it was impossible to read normal text) to solid.


HitmanIP7 05-14-2003 05:10 PM

I haven't downloaded the nVidia driver.

Thanks for the info, but I dont have Windows on the machine, only Linux, so I cant do what you said. If I get the same problem as you though, then at least I know what to try.

I dont know the option to edit the proccess in LILO, or the key to press. I have looked around, and searched on Google, but I cant seem to find what it is.

All times are GMT -5. The time now is 07:02 PM.