LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Bittorent help (https://www.linuxquestions.org/questions/linux-software-2/bittorent-help-264349/)

jh48107 12-09-2004 03:51 AM

Bittorent help
 
Hey I am having a lot of trouble getting bittornado to work. I have it install along with all the wxPython stuff but when I try to run the gui I get this message

Traceback (most recent call last):
File "./btdownloadgui.py", line 21, in ?
from BitTorrent.ConfigReader import configReader
File "/home/joseph/bittorrent-CVS-shadowsclient/BitTorrent/ConfigReader.py", line 4, in ?
from wxPython.wx import *
File "/usr/lib/python2.3/site-packages/wxPython/__init__.py", line 20, in ?
import wxc
ImportError: /usr/lib/python2.3/site-packages/wxPython/wxc.so: cannot open shared object file: No such file or directory

But I know that wxc.so is there where is is looking

]$ slocate wxc.so
/usr/lib/python2.3/site-packages/wxPython/wxc.so

I really dont see why it is not working. any Ideas?

reddazz 12-09-2004 08:40 AM

This problem has persisted for sometime on various distros. Just download azureus and hopefully your problem will be solved.

jh48107 12-09-2004 04:17 PM

Ok I really think the problem that I am having is with my amd 64 processor because when I ran a strace on the command the output had a whole lot of lib 64 stuff in it. I had to install the i386 rpm of wx because a 64 native one does not exist.
Ok so on to my next problem I tried to rebuild the rpm from source but I get an error at the end.

running build_ext
error: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)
error: Bad exit status from /var/tmp/rpm-tmp.20930 (%build)

for some reason it is looking for Makefile in lib when python2.3 exists in /usr/lib64/python2.3

is there any way I can correct this? do I have to change the spec file or somthing. any help on this would be nice because rpm is not really my strong point.

Also I installed Azarus and the jvm but in fedora 3 the /bin directory has a lot of java placeholders
that conflict with the actuall java vm. I installed all my java stuff is /usr/local. How can I change the search path so that it finds the real program and not the placeholder?

jh48107 12-10-2004 01:27 AM

Ok so I got Azureus working all I had to do was change 2 lines in the script that launches it. But I am still confused about how to replace the java stuff that comes with fedora three.
Also If anybody knows how to get rpmbuild --rebuild to look in the 64 bit libraries I, and a bunch of other people who are having the same problem as me, would be very greatfull.


All times are GMT -5. The time now is 09:14 AM.