LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Bind-9.14 install from source (https://www.linuxquestions.org/questions/linux-software-2/bind-9-14-install-from-source-4175657256/)

Dain_Bramage 07-12-2019 03:18 AM

Bind-9.14 install from source
 
Hi,

I am running Zorin 15 and am trying to install Bind-9.14 from source by following the instructions here:

https://kb.isc.org/docs/aa-00768

However when I do

Code:

./configure --with-openssl --enable-threads --with-libxml2
I get

Code:

configure: error: sys/capability.h header is required for Linux capabilities support. Either install libcap or use --disable-linux-caps.
I have installed the following prior to compile

Code:

apt install libxml2 libssl-dev libxml2-dev python3-ply
I have tried

Code:

apt install linux-headers-$(uname -r)
and

Code:

apt-get install libpcap-dev
to no avail. Does anyone know the dependency I am missing?

Thank you in advance.

bathory 07-12-2019 04:10 AM

Quote:

configure: error: sys/capability.h header is required for Linux capabilities support. Either install libcap or use --disable-linux-caps.
Mind that it's libcap not libpcap, so you should search for the libcap-dev package. Ubuntu has this package, so I guess zorin that's based on ubuntu it should have it also.
Anyway, if you can't find it, you can disable capabilities, using the "--disable-linux-caps" option.

Also note that from bind-9.10.x onwards, threads are enabled by default for linux, so you don't need the "--enable-threads" option.


Regards

Dain_Bramage 07-12-2019 04:38 AM

Thank you Bathory :-)


All times are GMT -5. The time now is 05:10 PM.