-   Linux - Software (
-   -   Beryl install - X server - no screens found (

TotalLinuxNoob 03-06-2007 12:38 PM

Beryl install - X server - no screens found
Hello fellow users
Last night I came across beryl and decided that it would be worth the little effort of installing it.. I grabbed the script of the Beryl site to install it on my Ubuntu box (Edgy Eft).
It informed me I needed a restart but this advice was ignored and Beryl was run. It looked gooood. apart from some title bar and taskbar glitches everything seemed fine.

To fully enjoy my desktop on acid I decided to restart and now it fails to start the x server:
The error is:
No devices detected.
Fatal server error:
no screens found.

Directory /usr/share/X11/fonts/misc does not exist
/usr/share/X11/fonts/misc does not exist
..load more fonts..

More output:
Default generic monitor
generic video card
(even though nvidia drivers were installed)

It does try to loadmodule nvidia..

Is there an easy way to fix this? Like reinstalling drivers or other?
Obviously I would like to have another go at running Beryl once this issue is fixed.

Thanks all

TotalLinuxNoob 03-06-2007 02:24 PM

Ok, I ran sudo dpkg-reconfigure xserver-xorg and selected the nv driver instead of nvidia and I can get X back up. Great.

Unfortunately I won't be playing CoD using Wine for a while. Setting the driver to nvidia returns me to the no monitor found error (this happens when I run nvidia-xconfig).

Running Beryl now totally screws up the GUI. Well, it was to be expected..

The distraction that is AMSN refuses to load (Is this a bad thing? ;)) - wish not found. Reinstalling fails. tk not found.

glxgears: Error: couldn't get an RGB, Double-buffered visual

I have tried reinstalling the nvidia drivers with Automatix but this returns me to the problem of no screens found. Setting the driver to nv offers half a fix.

All times are GMT -5. The time now is 03:22 AM.