LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-29-2003, 11:06 AM   #1
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 31
Question .bash_profile not exec in xfce


Hai friends,

My problem is simple(!). I have installed xfce from the rpm's. Now, when I go into xfce, I see that my .bash_profile is not exec, so that all my path, and other variables are not set.

I had to finally add the variables to /etc/bashrc, but this is not a final solution. How to exec the .bash_profile on starting xfce? I even tries to put it in .xsession.

Also, I directly boot into XWindow, so I don't want to boot into init 3, and do all that startx stuff.

Thanx for suggestions.
 
Old 09-30-2003, 12:57 AM   #2
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Original Poster
Rep: Reputation: 31
Common guys, some one answer me.
 
Old 09-30-2003, 01:39 AM   #3
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
If I understand you correctly, you mean that when you start a terminal program, your bash_profile settings aren't used. If this is the case, then the solution is most likely to use the correct option(s) when you call the terminal program. Usually this means adding the option '-ls' to the call to your terminal in your menu or panel, but I can't say for sure since I don't know which terminal program you use. The '-ls' option works for xfterm, if that's what you're using. If not, check the man pages.

BTW, you should wait at least a day before you bump your thread.

Enjoy!
--- Cerbere
 
Old 09-30-2003, 05:21 AM   #4
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Original Poster
Rep: Reputation: 31
Well, suppose that I have installed java in /usr/java/j2sdk1.2.1_03/ (this is the default dir), and I have added its path and also the CLASSPATH variables to the .bash_profile, so I can use them from the shell(bash & xterm), and also from emacs.

Now, I can't use them from inside emacs, and I have to add the path to /etc/bashrc to stop from manually executing it each time I log in.

Is there any way to force the loading of .bash)profile when I login ??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xfce problems with task bar and xfce-panel aeruzcar Linux - Software 4 06-26-2006 06:29 AM
.bash_profile UmneyDurak Linux - General 1 10-18-2005 12:44 AM
.bash_profile wildcat22 Linux - General 3 04-13-2004 08:08 PM
.bash_profile sikandar Linux - Software 9 08-31-2003 11:01 AM
.bash_profile Wasim Haider Linux - General 2 09-16-2002 08:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration