-   Linux - Software (
-   -   bash: ./configure: No such file or directory (

gousers 08-27-2004 09:51 AM

bash: ./configure: No such file or directory

I'm fairly new to linux and am having a problem installing applications.

I have two installs of linux, one is fedora core 2 the other is slackware 10.

I've tried installing nagios on fedora and wine on slackware. I created a folder under \ called downloads on each machine and downloaded the tar files into the folder on each machine. extracted the files and tried to execute ./configure but on each machine I get No such file of directory.

I installed all packages from each distrubution.

Saw another post suggesting to check that gcc and make are installed.

gcc -v shows gcc version 3.3.3
gnu make 3.80 also present.

Any help appreciated.

PenguinPwrdBox 08-27-2004 10:01 AM

Well, you are almost right.
Suppose it's like this:

You downloaded wine to /downloads
You extract it, and now, there is a dir in /downloads called wine<date>.
cd to this new dir, so now, you are in /downloads/wine<date>
Now do ./configure

gousers 08-29-2004 04:21 PM

Thanks for replying.

I'm stilling trying to install wine.

I've downloaded Wine-20040813-i686-S10.tgz to folder /download/wine.

extracking the file creates to sub folders /download/wine/usr and /download/wine/install.

I've switch to each folder and type ./configure but get bash: ./configure: No such file or directory in both locations.

any ideas?


By the way, was able to compile and install nagios.

Andrew Benton 08-29-2004 04:50 PM

Not every app has a configure script. I don't know the details of wine as I've never installed it but generally applications have a README, plain text file in the source folder which may tell you what you need to do. Also worth looking for is a file called INSTALL. If it starts with "These are generic install instructions..." ignore it. There may even be a folder called doc with lots of documentation in it which may contain installation instructions. Also, check the applications website.

vavoem 08-30-2004 01:48 AM

if there is a configure file try to make it executable as root do the following

chmod a+x configure

PenguinPwrdBox 08-30-2004 01:50 AM

Not to mention - do the ./configure in the wine directory - not the sub dirs....

mhearn 09-01-2004 11:40 AM

You grabbed a slackpack. Slackware isn't really oriented towards newbies, you may find distros like Fedora easier. However, try investigating the "installpkg" command if you really want to use Slackware.

All times are GMT -5. The time now is 02:23 PM.