LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-29-2013, 03:10 AM   #1
eeluve
Member
 
Registered: Nov 2011
Location: Russia, SPb
Distribution: all of 'em
Posts: 49

Rep: Reputation: Disabled
bash autocomplete bug


Whenever I am trying to autocomplete filename or directory with TAB button, I am getting:
Code:
awk: read error (Is a directory)
Code:
sed: read error /home/ME/.ssh/config: Is a directory
, and nothing happens of course.
I am using bash completion, but don't really think it has something to do with the prob, as long as there is no mention of either awk or sed. I have diffed my .bashrc with .bashrc of the user who doesn't experience such problems. Copied his .profile chowning to me just for the sake of it. Checked /etc/profile, profile.d which contains bash-completion as well. Chowned -R my whole /home/ME, checked that all dir's got X for my user, including this /.ssh/config one which, in turn, is empty and I have no idea why it is being checked, even more I guess the debug messages I get, have absolutely nothing to do with my prob. I have no idea, what else. Please, give an advise. I am more than sure that it has nothing to do with my problem, but it happened the way, that my group id differs from uid. Everything is set correct, talking about these numbers, everywhere tho.
 
Old 11-29-2013, 03:25 AM   #2
hal8000b
Member
 
Registered: Mar 2001
Location: UK
Distribution: Mint, Arch, Debian7
Posts: 189

Rep: Reputation: 23
What distribution are you using?
In my ~/.ssh I only have known_hosts no config file (this is on Linux Mint).
Have you tried creating a new user, logging out and logging in as new user account?
 
1 members found this post helpful.
Old 11-29-2013, 03:48 AM   #3
eeluve
Member
 
Registered: Nov 2011
Location: Russia, SPb
Distribution: all of 'em
Posts: 49

Original Poster
Rep: Reputation: Disabled
Just a joke. Thank you. I removed /.ssh/config, which solved the issue. But do you have an explanation to this?
 
Old 12-02-2013, 03:24 PM   #4
hal8000b
Member
 
Registered: Mar 2001
Location: UK
Distribution: Mint, Arch, Debian7
Posts: 189

Rep: Reputation: 23
Removing ~/.ssh/config was in some way modified or corrupted.
As to why, I can only guess that you modified some file, or perhaps
had trouble accessing via SSH ?
At least you solved your problem though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] bash autocomplete space after match suicidaleggroll Linux - Newbie 2 08-07-2012 05:59 PM
Another Bash Bug??? FreeForEternity Linux - Software 3 11-27-2009 10:03 AM
Customizing Bash Autocomplete ramzak3k Linux - Software 2 01-07-2009 08:57 PM
bash scripting problem (bug?) zz9pluralzalpha Linux - Software 2 04-12-2005 02:51 PM
Is this a bug? (BASH and Z shells) KingofBLASH Linux - Software 4 09-14-2004 07:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration