LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   backup dejadup cannot function due missing software; unable to locate missing package(s) (https://www.linuxquestions.org/questions/linux-software-2/backup-dejadup-cannot-function-due-missing-software%3B-unable-to-locate-missing-package-s-4175578937/)

mike3644 05-03-2016 05:15 PM

backup dejadup cannot function due missing software; unable to locate missing package(s)
 
Backup fails to activate. Package name deja-dup-backend-gvfs could not be resolved (is message); & using terminal to force-compile with input apt-get -f install deja-dup-backend-gvfs . . . produces dead end.
Heres the terminal output:

mike@mike-Kudu-Professional:~$ sudo apt-get install deja-dup-backend-gvfs
[sudo] password for mike:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package deja-dup-backend-gvfs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'deja-dup-backend-gvfs' has no installation candidate
mike@mike-Kudu-Professional:~$
-----------------------------------------------------------
. . . "referred to by another package." Hmmm.
It would be nice if the "another package" were named.

I ran Boot Repair Disk from a thumb drive; no help from fsck.

Then, in terminal tried again, with this output:

mike@mike-Kudu-Professional:~$ sudo dpkg --configure -a --force-all
Setting up amavisd-new (1:2.10.1-2ubuntu1) ...
Creating/updating amavis user account...
Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "start" failed.
dpkg: error processing package amavisd-new (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: amavisd-new-postfix: dependency problems, but configuring anyway as you requested:
amavisd-new-postfix depends on amavisd-new (= 1:2.10.1-2ubuntu1); however:
Package amavisd-new is not configured yet.

Setting up amavisd-new-postfix (1:2.10.1-2ubuntu1) ...
postconf: warning: policy-spf_time_limit: unknown parameter
postconf: warning: /etc/postfix/main.cf: unused parameter: policy-spf_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: policy-spf_time_limit=3600s
Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "restart" failed.
dpkg: error processing package amavisd-new-postfix (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
amavisd-new
amavisd-new-postfix
mike@mike-Kudu-Professional:~$
-------------------------------------------------------------

Thanks

-------------------------------------------------------------

Just tried this; will now relent awaiting fix from Ubuntu as it appears this build of 16.04 LTS is buggy:

mike@mike-Kudu-Professional:~$ sudo dpkg --configure -a --force-all
Setting up amavisd-new (1:2.10.1-2ubuntu1) ...
Creating/updating amavis user account...
Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "start" failed.
dpkg: error processing package amavisd-new (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: amavisd-new-postfix: dependency problems, but configuring anyway as you requested:
amavisd-new-postfix depends on amavisd-new (= 1:2.10.1-2ubuntu1); however:
Package amavisd-new is not configured yet.

Setting up amavisd-new-postfix (1:2.10.1-2ubuntu1) ...
Selected policy name, policy-spf, already in master.cf. Master.cf not updated.
Selected service name, smtp-amavis, or smtpd port, 10025, already in master.cf. Master.cf not updated.

Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "restart" failed.
dpkg: error processing package amavisd-new-postfix (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
amavisd-new
amavisd-new-postfix
mike@mike-Kudu-Professional:~$
-----------------------------------------------
Here's another try at resolving my dilemma, working it from a slightly different angle:

mike@mike-Kudu-Professional:~$ sudo apt-get update && sudo apt-get upgrade
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [92.2 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:3 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [27.7 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [93.3 kB]
Get:5 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [27.7 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [9,264 B]
Get:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [188 B]
Get:8 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [64 B]
Get:9 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [64 B]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [64 B]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata [158 B]
Get:12 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [4,628 B]
Get:13 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [4,620 B]
Get:14 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [2,756 B]
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [82.2 kB]
Get:16 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [190 B]
Get:17 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201 kB]
Get:18 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [64 B]
Get:19 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [64 B]
Get:20 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [64 B]
Get:21 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [159 B]
Get:22 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196 kB]
Get:23 http://us.archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
Get:24 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
Get:25 http://us.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages [8,344 B]
Get:27 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages [8,684 B]
Get:28 http://us.archive.ubuntu.com/ubuntu xenial/restricted Translation-en [2,908 B]
Get:29 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata [186 B]
Get:30 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7,532 kB]
Get:31 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages [7,512 kB]
Get:32 http://us.archive.ubuntu.com/ubuntu xenial/universe Translation-en [4,354 kB]
Get:33 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [3,410 kB]
Get:34 http://us.archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7,448 kB]
Get:35 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [144 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [140 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en [106 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata [63.8 kB]
Get:39 http://us.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons [230 kB]
Get:40 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [36.9 kB]
Get:41 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [36.8 kB]
Get:42 http://us.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [14.0 kB]
Get:43 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [5,487 B]
Get:44 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [4,408 B]
Get:45 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [64 B]
Get:46 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [64 B]
Get:47 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [64 B]
Get:48 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata [157 B]
Get:49 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [9,012 B]
Get:50 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [9,016 B]
Get:51 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [5,980 B]
Get:52 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [157 B]
Get:53 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [64 B]
Get:54 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [64 B]
Get:55 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [64 B]
Get:56 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [158 B]
Get:57 http://us.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [28 B]
Get:58 http://us.archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages [28 B]
Get:59 http://us.archive.ubuntu.com/ubuntu xenial-backports/main Translation-en [28 B]
Get:60 http://us.archive.ubuntu.com/ubuntu xenial-backports/restricted amd64 Packages [28 B]
Get:61 http://us.archive.ubuntu.com/ubuntu xenial-backports/restricted i386 Packages [28 B]
Get:62 http://us.archive.ubuntu.com/ubuntu xenial-backports/restricted Translation-en [28 B]
Get:63 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [28 B]
Get:64 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [28 B]
Get:65 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [28 B]
Get:66 http://us.archive.ubuntu.com/ubuntu xenial-backports/multiverse amd64 Packages [28 B]
Get:67 http://us.archive.ubuntu.com/ubuntu xenial-backports/multiverse i386 Packages [28 B]
Get:68 http://us.archive.ubuntu.com/ubuntu xenial-backports/multiverse Translation-en [28 B]
Fetched 35.8 MB in 1min 41s (354 kB/s)
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
libssl1.0.0 openssl
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 1,613 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libssl1.0.0 amd64 1.0.2g-1ubuntu4.1 [1,122 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 openssl amd64 1.0.2g-1ubuntu4.1 [491 kB]
Fetched 1,613 kB in 5s (295 kB/s)
Preconfiguring packages ...
(Reading database ... 186199 files and directories currently installed.)
Preparing to unpack .../libssl1.0.0_1.0.2g-1ubuntu4.1_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.2g-1ubuntu4.1) over (1.0.2g-1ubuntu4) ...
Preparing to unpack .../openssl_1.0.2g-1ubuntu4.1_amd64.deb ...
Unpacking openssl (1.0.2g-1ubuntu4.1) over (1.0.2g-1ubuntu4) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up amavisd-new (1:2.10.1-2ubuntu1) ...
Creating/updating amavis user account...
Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "start" failed.
dpkg: error processing package amavisd-new (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of amavisd-new-postfix:
amavisd-new-postfix depends on amavisd-new (= 1:2.10.1-2ubuntu1); however:
Package amavisd-new is not configured yet.

dpkg: error processing package amavisd-new-postfix (--configure):
dependency problems - leaving unconfigured
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up openssl (1.0.2g-1ubuntu4.1) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
amavisd-new
amavisd-new-postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)
mike@mike-Kudu-Professional:~$

ShadowCat8 05-03-2016 07:59 PM

Greetings,

While I do not use Ubuntu regularly, I have to question what the dependency of amavisd-new is for Deja-dup?

Deja-dup is a local backup program, so why does it need to filter emails? Or was that just leftover from a previous install session that is messing up the Deja-dup installation?

And, as far as being able to find out what package depends on which package, on the Gentoo side, we use 'equery' from gentoolkit:

Code:

tech8 plugins # equery depgraph app-backup/deja-dup
 * Searching for deja-dup in app-backup ...

 * dependency graph for app-backup/deja-dup-34.0
 `--  app-backup/deja-dup-34.0  amd64
  `--  app-crypt/libsecret-0.18.4  (app-crypt/libsecret) amd64  [vala]
  `--  dev-libs/glib-2.46.2-r2  (>=dev-libs/glib-2.34) amd64
  `--  dev-libs/libpeas-1.16.0  (>=dev-libs/libpeas-1.0) amd64
  `--  x11-libs/gtk+-3.18.7  (>=x11-libs/gtk+-3.10) amd64
  `--  x11-libs/libnotify-0.7.6-r3  (>=x11-libs/libnotify-0.7) amd64
  `--  app-backup/duplicity-0.6.26  (>=app-backup/duplicity-0.6.23) amd64
  `--  dev-libs/dbus-glib-0.102  (dev-libs/dbus-glib) amd64
  `--  gnome-base/nautilus-3.18.5  (gnome-base/nautilus) amd64
  `--  app-text/yelp-tools-3.18.0  (app-text/yelp-tools) amd64
  `--  dev-lang/vala-0.30.1  (dev-lang/vala) amd64
  `--  dev-lang/vala-0.28.1  (dev-lang/vala) amd64
  `--  dev-lang/vala-0.26.2  (dev-lang/vala) amd64
  `--  dev-lang/vala-0.22.1  (dev-lang/vala) amd64
  `--  dev-perl/Locale-gettext-1.50.0-r1  (dev-perl/Locale-gettext) amd64
  `--  virtual/pkgconfig-0-r1  (virtual/pkgconfig) amd64
  `--  dev-util/intltool-0.50.2-r1  (dev-util/intltool) amd64
  `--  sys-devel/gettext-0.19.4  (sys-devel/gettext) amd64
  `--  sys-devel/make-4.1-r1  (sys-devel/make) amd64
  `--  dev-util/cmake-3.3.1-r1  (>=dev-util/cmake-2.8.12) amd64
  `--  app-arch/xz-utils-5.2.2  (app-arch/xz-utils) amd64
  `--  sys-apps/sed-4.2.1-r1  (>=sys-apps/sed-4) amd64
  `--  dev-util/desktop-file-utils-0.22  (dev-util/desktop-file-utils) amd64
  `--  x11-misc/shared-mime-info-1.4  (x11-misc/shared-mime-info) amd64
  `--  gnome-base/dconf-0.24.0  (gnome-base/dconf) amd64
  `--  gnome-base/gvfs-1.28.0  (gnome-base/gvfs) ~amd64  [fuse]
[ app-backup/deja-dup-34.0 stats: packages (26), max depth (1) ]
tech8 plugins #

So, we can see the gvfs and nautilus dependencies from GNOME directly, but there is no email, smtp and/or MTA dependencies for Deja-dup. So, I think you might be fighting two different issues at the same time. As I started to look deeper at this, I came to realize that deja-dup-backend-gvfs has been deprecated by the Ubuntu devs in their push to deprecate Python2.

As far as the amavisd-* failures, you may want to try to completely uninstall (and reinstall, if needed,) both amavisd-new and amavisd-new-postfix to see if that gets you back to a sane state with your package management system.

HTH. Let us know.


All times are GMT -5. The time now is 04:44 AM.