-   Linux - Software (
-   -   Back Track 5 - VirtualBox Driver Error (

Ninjex 06-23-2012 06:20 PM

Back Track 5 - VirtualBox Driver Error
Hello, I have been looking for a solution to this issue since last night, but nothing seems to be helping me out.

In case you guys need it:

# uname -a
Linux bt 3.2.6 #1 SMP Fri Feb 17 10:34:20 EST 2012 x86_64 GNU/Linux

I had VirtualBox installed but it was not working so I ran a uninstall on it with the purge command and search the root directory / to make sure there are no more "virtualbox" files or programs, and there isn't.

I then began to re-install it, which is what the manufacture site said was the best option to trouble shoot my problem.

I ran the install again, and I am still receiving the errors.

They are as follows:

# virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (3.2.6) or it failed to
load. Please recompile the kernel module and install it by

sudo /etc/init.d/vboxdrv setup

You will not be able to start VMs until this problem is fixed.

So of course, I run the command listed above, and come up with:

# sudo /etc/init.d/vboxdrv setup
* Stopping VirtualBox kernel modules [ OK ]
* Uninstalling old VirtualBox DKMS kernel modules [ OK ]
* Trying to register the VirtualBox kernel modules using DKMS
Error! Bad return status for module build on kernel: 3.2.6 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/vboxhost/4.1.0/build/ for more information.

* Failed, trying without DKMS
* Recompiling VirtualBox kernel modules
* Look at /var/log/vbox-install.log to find out what went wrong

So I look into the vbox-install.log and basically instead of posting all of the output code (which is a lot) I will just show the error which I need to correct:

Run 'make oldconfig && make prepare' on kernel src to fix it:

Failed to install using DKMS, attempting to install without
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 -C /lib/modules/3.2.6/build modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*

So I ran:

cd /usr/src/linux-headers-3.2.6#

# make oldconfig && make prepare
scripts/kconfig/conf --oldconfig Kconfig
# configuration written to .config
scripts/kconfig/conf --silentoldconfig Kconfig
CHK include/linux/version.h
CHK include/generated/utsrelease.h

I go back to run:
# sudo /etc/init.d/vboxdrv setup

but still come up with the same error.
I just now also found something weird out, my adobe flash player continues to crash, so I went to do an install and no matter what I try and install via "apt-get install program-name" and no matter what program I choose, even if it is already installed, I get the following output code with virtual box in it, for example:

# apt-get install firefox
Reading package lists... Done
Building dependency tree
Reading state information... Done
firefox is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up virtualbox-ose-dkms (3.1.6-dfsg-2ubuntu2) ...
Removing old virtualbox-ose-3.1.6 DKMS files...

Deleting module version: 3.1.6
completely from the DKMS tree.
Loading new virtualbox-ose-3.1.6 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.6
Building for architecture x86_64
Building initial module for 3.2.6

Error! Bad return status for module build on kernel: 3.2.6 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/virtualbox-ose/3.1.6/build/ for more information.
dpkg: error processing virtualbox-ose-dkms (--configure):
subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

To those of you who actually read this entire post, I thank you and that you at least took the time to try and help!
I have now figured out a solution to the issue I had.
If anyone needs the measures I took to trouble shoot the issue, feel free to post below.

Any help would be appreciated,
Thanks in advance!


All times are GMT -5. The time now is 03:58 PM.