-   Linux - Software (
-   -   Autologin with GUI, and shutdown (

gregorya 06-12-2004 06:40 AM

Autologin with GUI, and shutdown
Hi all, two questions. I'm running Mandrake 10.0 Official with KDE.

1: If I set my computer to autologin, then sometimes (I'd guess around 10% of the time) it seems as though the GUI fails to load properly. It either stops with a blue screen with the cursor as a black cross, which I can move, to no avail, in which case I can ctrl-alt-f1 or whatever to get into console, but can't seem to get that GUI to work at all, or I get a severely messed up array of lines accross the screen.

I presume from the latter that its a graphical problem - would I be right in guessing that the X is displayed when Xfree is loading up? I had problems with my graphics card in 10.0 community (its a intel845, which many people seem to have problems with), but those problems seem to have been fixed now, and these problems I get also occured in 10.0 community.

However, the strange thing is, if I turn off autologin, and start KDE manually it never ever goes wrong. Whats the difference between the two?

Finally, if this suggests anything, I get the impression (not certain) that it continues to not load properly despite reboots until I boot into windows instead and then reboot back to linux.

2. Possibly not a linux related problem, but sometimes on shutdown my computer fails to turn off. In linux it gets to "Shutting Down" and just hangs there, so I have to hold down the power button until it turns off. I get similar in windows sometimes, but in windows it could be anything :S

I'm guessing this is a hardware problem?

Thanks for any help,


Andrew Benton 06-12-2004 08:18 AM

Sometimes there are worse things than getting an error message, not getting an error message is much worse. Does it say anything usefull in /var/log/XFree86.0.log or /var/log/sys.log ? I'm just speculating, but something that could cause KDE to hang is a bad font. If fontconfig is stuck then the whole process can hang. Look in /etc/fonts/fonts.conf for the list of directories it scans for fonts and then (as root) cd into each of them and run

mkfontscale && mkfontdir

Delete any fonts it complains about then run fc-cache
That's just my guess at what the problem is, sorry if it's no help.

The `computer not shutting down' problem is to do with acpi. There are some different options you can pass the kernel at boot time, you'd need to edit lilo.conf and then run lilo. This thread seems to suggest acpi=on is the way to go

All times are GMT -5. The time now is 12:04 AM.