-   Linux - Software (
-   - fails: libtool.m4 / version mismatch (

jrtayloriv 01-08-2008 12:23 PM fails: libtool.m4 / version mismatch
I am trying to run an script and am receiving the following error:


checking for correct version... no
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and have a version mismatch! ***
*** (libtool.m4 = 1.5.24, = 1.5.22) ***

Please run:

libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.
I tried running libtoolize --copy --force as it said and received the following message:


Using `AC_PROG_RANLIB' is rendered obsolete by `AC_PROG_LIBTOOL'

I tried reinstalling m4, autoconf, libtool, and make. No dice.

So then I tried copying /usr/share/libtool/ into the build directory, to overwrite the that was in there. Now gets through without errors.

I've never had to do this before,though (copying Is this something that is normally done automatically? How do I fix it?


Emerson 01-09-2008 01:06 PM

Search and file a bug if it's new.

All times are GMT -5. The time now is 02:37 PM.