LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-27-2012, 12:39 PM   #1
ted_chou12
Member
 
Registered: Aug 2010
Location: Zhongli, Taoyuan
Distribution: slackware, windows, debian (armv4l GNU/Linux)
Posts: 430
Blog Entries: 30

Rep: Reputation: 2
autofs doesnt turn ghost option off


Hi, I got udev to work, but I guess I have another problem. I do not have the ghost option on in my auto.master:
Code:
root:# cat /etc/auto.master
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
/misc                   /etc/auto.misc  --timeout=60
#
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
#
/misc                   -hosts
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master
My auto.misc file:
Code:
root:# cat /etc/auto.misc
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

#cd             -fstype=iso9660,ro,nosuid,nodev                 :/dev/cdrom
cd              -fstype=iso9600,ro                              :/dev/sr0

# the following entries are samples to pique your imagination
#linux          -ro,soft,intr                                   ftp.example.
/pub/linux
#boot           -fstype=ext2                                    :/dev/hda1
#floppy         -fstype=auto                                    :/dev/fd0
#floppy         -fstype=ext2                                    :/dev/fd0
#e2floppy       -fstype=ext2                                    :/dev/fd0
#jaz            -fstype=ext2                                    :/dev/sdc1
#removable      -fstype=ext2                                    :/dev/hdd
hdd             -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd
hdd1            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd1
hdd2            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd2
hdd3            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd3
hdd4            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd4
hdd5            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd5
hdd6            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd6
hdd7            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd7
hdd8            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd8
hdd9            -fstype=ntfs,utf8,uid=1000,gid=100              :/dev/hdd9
fdisk           -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk
fdisk1          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk1
fdisk2          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk2
fdisk3          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk3
fdisk4          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk4
fdisk5          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk5
fdisk6          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk6
fdisk7          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk7
fdisk8          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk8
fdisk9          -fstype=vfat,utf8,uid=1000,gid=100              :/dev/fdisk9
[/code]
The problem is that there are directories in misc despite not all are mounted:
Code:
vector://misc
root:# ls
/bin/ls: cannot access fdisk: No such file or directory
/bin/ls: cannot access hdd2: No such file or directory
cd/      fdisk2/  fdisk5/  fdisk8/  hdd1/  hdd4/  hdd7/
fdisk/   fdisk3/  fdisk6/  fdisk9/  hdd2/  hdd5/  hdd8/
fdisk1/  fdisk4/  fdisk7/  hdd/     hdd3/  hdd6/  hdd9/
Thanks,
Ted
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network card doesnt work after i turn it off and on slinky2004 Slackware 5 09-24-2005 10:59 PM
sound doesnt turn on automatically invinciblegod Linux - General 2 07-27-2005 01:37 PM
autofs works, but doesnt show automounted directory nef Linux - Software 1 03-02-2005 07:12 PM
I have Ghost For Linux (G4L) -- how to avoid problems with Click and Clone option? loninappleton Linux - Newbie 0 10-27-2004 07:27 PM
click and clone option in g4l (Ghost For Linux) loninappleton Linux - Newbie 0 10-24-2004 03:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration