LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-20-2003, 12:07 AM   #1
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Rep: Reputation: 15
Audio CD Copying


Anyone know of a program that will copy audio CD's on the fly? I used to do it with gnometoaster, but since I got my new fast CD-RW drive, it's ass slow for some reason (like at less than 1x) and when it finishes the CD doesn't work. I've tried XCDRoast, but it won't do audio on the fly, I've tried cdbakeoven, it doesn't work at all, and I've tried k3b which is absolute shit (I hate KDE). I also tried "cdda2wav -D/dev/cdrom -Ocdr -t1 | cdrecord -v -pad speed=48 dev=0,0,0 -dao -audio -fix -text" on the command line (as root) but that just exited right away saying it fixitated and nothing else.

Anyone have any ideas? What could be the problem with gtoaster? I'm trying to burn at 48x, and I have a 52x reader and a 52x burner, so it should work. I'm on SuSE 8.2, but I had the same problem on my old machine (same CD-RW drive) on Mandrake 8.2.
 
Old 10-20-2003, 12:11 AM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
maybe dma isn't enabled for your new burner? maybe you also need to do scsi emulation at boot up too. maybe it's how you set up your new cdrw drive (master/slave thing).

but what do you mean on the fly? i've used xcdroast to burn a duplicate cd in raw mode and i don't think it had to create an image.
 
Old 10-20-2003, 03:07 PM   #3
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
The new drive is setup as SCSI, I can burn to it just fine. I also was able to make a copy in XCDRoast, but I had to create an image first. It'll create a direct copy on the fly, but not for audio CD's. What is the raw mode of which you speak? That might be the solution, although I want to be able to burn CD-Text, since I can see it on my discman. Perhaps gnome toaster just doesn't like doing it at a fast speed. I'll try turning it down to 16x or something and see if that works.
 
Old 10-20-2003, 05:43 PM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
I'm curious as to why it would be so important to be able to record audio on the fly. Copying a track with xcdroast is a whole lot faster than to record it as it plays, and I'm not sure that I understand why you would want to spend an hour or so playing all the tracks you want to record rather than to just copy them one by one, then burn the lot of them to a CD in just a few minutes. It sounds like the main issue you're facing is just that the CD's that you burn turn out to be unusable later. If so, the cause is probably that you're trying to burn at a speed higher than what your CD-RW can handle, despite its 52X speed rating. (My experience has always been that the performance ratings of CD-RW's are, shall we say "optimistic", and that you're better off burning at a lower speed than the max.) Have you tried burning at 32X or 24X? -- J.W.
 
Old 10-20-2003, 07:08 PM   #5
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
It takes twice as long to copy a CD when I have to precache it first than if I do it on-the-fly (even at 24x). Last time I tried it at 24x, it had the same problem (going really slow, then not working), but I'll try it again.
 
Old 10-20-2003, 08:27 PM   #6
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well, i don't know. xcdroast will dupe cds in raw-sao mode because my cd burner supports raw burning. basically it's an exact binary duplicate of the original cd. good for duplicating cds like game install cds where some game vendors purposefully introduce crc errors to prevent cd copying. but i really don't know why xcdroast is making you do an image. have you ran xcdroast as root and checked your setup? maybe it's still listing the old cdrw in there which may cause you some havoc.
 
Old 10-20-2003, 11:26 PM   #7
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
Nope, the old CD-RW has never been installed on this machine, it's brand new. The old one was only on the old machine, and the new one was on the old machine for a couple months. I'll look for the raw copy and see if it works. I could probably live without CD-Text for now.

I tried it at 24x in GnomeToaster and I still had the same problem.
 
Old 10-20-2003, 11:30 PM   #8
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
I can't find the raw copy thing.

One other thing I thought of: Could the problem be that my CD-ROM drive isn't setup as SCSI?
 
Old 10-20-2003, 11:39 PM   #9
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
Not to hijack the thread, but I have yet to figure out how to burn cds with text. I have tried the image thing with xcdroast... tried copying them from xcdroast and then burning them... added all the ide tags to my grip oggs... commandline with a toc file... nothing seems to work... can anyone point me int he right direction?
 
Old 10-21-2003, 12:11 AM   #10
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
GnomeToaster burns CD's with CD-Text quite nicely.

Anyway, I've now setup my reader as an ATAPI SCSI device in GnomeToaster, and I can burn on-the-fly at 16x without incident. Fast enough for me, one hell of a lot faster than creating an image, then burning at 24x.
 
Old 10-21-2003, 12:24 AM   #11
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by CanadianPenguin
I can't find the raw copy thing.

One other thing I thought of: Could the problem be that my CD-ROM drive isn't setup as SCSI?
there isn't a setting for it in xcdroast AFAIK. if you're burner itself supports raw burning, you'll see it when you duplicate the cd the textbox of the progress/output dialog as xcdroast will show a line with something like:

burn mode: RAW-SAO

but anyway, glad you got it somewhat sorted, even though i did ask about something about scsi.
 
Old 10-21-2003, 05:31 PM   #12
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
OK, bigger problem now. It seems to burn fine at 16x, goes quick, finishes successfully. So, I pop my burned CD into my CD player, and go to listen to it. It displays the CD-Text fine, and I can go forward to the tracks, but there's no sound at all. Also, it doesn't look like it's reading anything from the CD-ROM drive when it's burning, so I'm a little confused as to what's happening. Also, when I'm burning at 16x, it says the buffer is always 100% full, whereas before when I burned at 16x (I got it to work once on the old machine), it was only about 3% full the whole time.

Any idea on either problem? I have the CD-ROM drive setup as ATAPI now (SCSI ID set to ATAPI:1,0 and "Use SCSI interface for DAE" checked in the preferences, whatever that means). The device file is still set as /dev/cdrom, not /dev/scd# like my burner is. I think that this might be the problem, the system isn't recognizing the reader as SCSI. Any idea how to set this up properly? The burner is setup as SCSI just fine.

My lesson from this thread: I'm never buying anything IDE again. It's just stupid. I have an extra SCSI card laying around unused anyway.
 
Old 10-21-2003, 06:22 PM   #13
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
So, I tried burning as root instead of a normal user. It fixes the no-audio problem, but it takes half an hour to burn and it still says buffer is 100% full the whole time. This is just stupid, I burned on-the-fly faster than that with my old 4x burner and 16x reader.
 
Old 10-21-2003, 08:16 PM   #14
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
try a different thingamobob. how is your set up? is the cdrw and the source cdrom on the same channel? do you have the cdrw set up as the master and the cdrom set up as the slave? if the cdrom is slower and is set to master then it will slow down the cdrw.... i think....

but anyway, if your source cdrom is set to /dev/cdrom, just right click on /dev/cdrom and see where it points to. my guess it will be something /dev/hdx where x is a letter for b, c, d, etc...

you can try to set scsi emulation for that channel in your boot loader.

grub ex.

Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,10)
#          kernel /boot/vmlinuz-version ro root=/dev/hda11
#          initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=10
#splashimage=(hd0,10)/boot/grub/splash.xpm.gz
splashimage=(hd0,10)/boot/grub/techsplash.xpm.gz
password --md5 *edited by me for posting purposes*
title Red Hat Linux 7.3
	root (hd0,10)
	kernel /boot/vmlinuz-2.4.18-10 ro root=/dev/hda11 hdb=ide-scsi hdc=ide-scsi
	initrd /boot/initrd-2.4.18-10.img
title Microsoft Windows ME
	rootnoverify (hd0,0)
	chainloader +1
this is the line to look at. hdb is my cdrw and hdc is my dvdrom/cdrom.
kernel /boot/vmlinuz-2.4.18-10 ro root=/dev/hda11 hdb=ide-scsi hdc=ide-scsi

if you got kudzu running on boot, it should create other /dev/cdromX links where X is a number and where /dev/cdromX will point to /dev/scdX. you can save yourself some editing of fstab by deleting the old /dev/cdrom that points to /dev/hdx and renaming /dev/cdromX, pointing to /dev/scdX, to /dev/cdrom
 
Old 10-21-2003, 11:47 PM   #15
CanadianPenguin
Member
 
Registered: Oct 2003
Distribution: Ubuntu "Hoary" - The best distro around by a long shot.
Posts: 116

Original Poster
Rep: Reputation: 15
I have it setup with my CD-ROM and my CD-RW both on the second channel, with the CD-ROM as the master and the RW as the slave. The reader is an LG 52x and the burner is a Sony 52x24x52, so they should be pretty compatible speed-wise. I suppose I could try switching them around.

Thanks for the advice on the SCSI emulation, I'll try that tomorrow and see if it helps any.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
copying audio cds skoot Linux - Newbie 8 05-18-2005 07:56 AM
copying audio from dvds linuxmaier Linux - Software 3 04-29-2005 01:26 PM
Copying Audio CD's exactly squabsy Linux - Software 5 03-24-2004 12:47 PM
Copying an Audio CD robert_81 Linux - Software 2 12-06-2003 04:08 PM
Problem copying audio CDs Wynd Linux - General 2 05-05-2003 07:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration