-   Linux - Software (
-   -   Audacious question (

methodtwo 08-06-2009 12:05 PM

Audacious question
Hi there
How do i play audio CDs with audacious?.I'm running gentoo and have KDE3.5 as my desktop.When i load an audio Cd nothing happens.I've tried mounting the cdrom drive but got this error:

mount: block device /dev/hda is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hda,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

I don't know which fs type to specify and how.
Also i've tried:

#audaciuos2 /dev/cdrom
but got this error:

I/O warning : failed to load external entity "/root/.config/audacious/playlist.xspf"
LASTFM: (cleanup) Cleanup finished

So how do i play an audio cd with audacious then?
Am i to understand that you have to rip CDs in kde3.5 before you can play them
Yes i could upgrade to a newer kde but kde4.3 is masked at the moment(gentoo term for still lited as unstable
Any help would be great thenk you in advance

David the H. 08-06-2009 06:36 PM

Audio CDs do not contain filesystems as such, so they can't be mounted. And no, you don't have to rip CDs in order to play them. Where did you get that misconception? All you need is a player that can read cda data straight from the CD drive. This includes most of the major ones, including audacious.

But you're going about it all wrong trying to use the file browser to load it. Audacious has a separate CD input plugin that accesses the drive directly. The function is accessed through the menu option called "plugin services", which should show up on all your right click menus or when you click on the "add files" button. If it doesn't work, go to your input plugins config and make sure the "CD Audio Plugin" is configured for the correct device. If you don't have it at all, then either your version of audacious wasn't compiled with CD support, or something is keeping the plugin from loading.

P.S. The error message you're getting at the end has nothing to do with your attempted CD playback. It's showing up because you're trying to run audacious as root. It's not finding a default playlist in your /root directory (probably because you've never used the program as root before), so it spits out an "error"--but it's really just an informative message in this case.

In any case, you generally shouldn't run programs as root unless absolutely necessary, and playing an audio CD does not fall into that category. ;)

All times are GMT -5. The time now is 04:55 AM.