LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-02-2017, 07:56 AM   #1
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,994

Rep: Reputation: 163Reputation: 163
Atril - long delay in opening pdf


I am running Atril 1.16.1 on CentOS 7.3 with the Mate desktop. When I first attempt to open a pdf file after a reboot or login - have not regressively tested yet - it takes a LONG time - perhaps 30 seconds. I observed in System Monitor that Atril shows a Waiting Channel "autofs4_wait." I have autofs running with several nfs mounts to remote servers, most of which are not on-line unless I need to access something on them. I suspect that Atril is trying to interrogate these dead links.

I recall many years ago OpenOffice or perhaps it was Star Office at the time would experience something similar by trying to access the Internet when my dialup connection was not connected. I remember disabling something in Office which told it not to try and phone home or whatever it was doing.

Does anyone know how to disable Atril from trying to explore the whole universe before opening the file it has been told to open?

TIA,

Ken
 
Old 03-02-2017, 09:54 AM   #2
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,994

Original Poster
Rep: Reputation: 163Reputation: 163
For what it is worth.... I edited /etc/autofs.config, uncommented negative_timeout and set it to 15 (seconds). I also removed a couple of lines from /etc/sysctl.conf which I had added to disable ipv6. The latter change was in response to disabling ipv6 hosing the startup of the nfs daemon after a reboot. Not sure if one or both of these impacted Atril. I will keep testing.

Ken
 
Old 03-03-2017, 08:38 AM   #3
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,994

Original Poster
Rep: Reputation: 163Reputation: 163
For whatever reason Atril is now functioning correctly. I am closing this thread as Resolved although I have no idea how it was resolved

Ken
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Greylisting delay too long chiglet Linux - Newbie 2 02-07-2012 07:42 AM
some apps opening after a few minutes delay 666 Debian 6 08-21-2006 09:25 AM
Delay opening same M$ Word file dorian33 Linux - Networking 0 10-13-2005 12:53 PM
long delay dummyagain Programming 1 10-28-2003 04:49 AM
lilo long delay??? comtronics Debian 2 10-22-2003 03:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration