LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Ati_drivers+kernel-2.6 (https://www.linuxquestions.org/questions/linux-software-2/ati_drivers-kernel-2-6-a-106427/)

robo_br 10-20-2003 03:58 PM

Ati_drivers+kernel-2.6
 
I am trying to use the ati drive for my Radeon8500 in the kernel-2.6beta8
But look the problem when I go to the /lib/modules/fglrx and /lib/modules/fglrx/buil_mod


1- /lib/modules/fglrx/buil_mod

ATI module generator V 2.0
==========================
initializing...
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.0-test8/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.0-test8'
*** Warning: Overriding SUBDIRS on the command line can cause
*** inconsistencies
make[2]: `arch/i386/kernel/asm-offsets.s' is up to date.
Building modules, stage 2.
MODPOST
*** Warning: "VMALLOC_VMADDR" [/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko] undefined!
make[1]: Leaving directory `/usr/src/linux-2.6.0-test8'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.

2- /lib/modules/fglrx

- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
FATAL: Error inserting fglrx (/lib/modules/2.6.0-test8/kernel/drivers/video/fglrx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
failed.

robo_br 10-20-2003 05:13 PM

nobody did it yet?

I am :newbie:


All times are GMT -5. The time now is 10:01 AM.