-   Linux - Software (
-   -   ATI Radeon Mobility HD5870/Asus G73JH & fglrx issues (

grubber33 05-05-2011 04:18 AM

ATI Radeon Mobility HD5870/Asus G73JH & fglrx issues
Hello all, coming back to linux after a few years away and I'm trying to get it set up on my Asus G73JH laptop. Problem is the closed-source drivers aren't playing nice. I can get it to start with the "radeon" driver but when I try to use fglrx, either through a manual xorg.conf change or aticonfig, I get a black screen (or a couple times a white blob moving across the screen) and then the system hangs. The biggest problem with this is I can't access the output from the X server and nothing is being written to the log files (probably because I have to hard-reboot). I've googled and read just about everything I can and I'm pretty much lost for ideas now. I'm not too good with troubleshooting Linux since it's been a while but there are a couple things that would be really helpful to me: a way to save whatever X puts out before the system hangs and a comparison from someone who plays decently graphics-intensive games between fglrx and the open source driver because I don't mind using the open source drivers as long as performance is comparable. Any extra information I can post I will as requested but I think being able to review the X output is a good place to start! Any help is greatly appreciated!


adamk75 05-05-2011 04:30 AM

Does this laptop have switchable graphics?


markush 05-05-2011 06:59 AM

Hello grubber33,

as you expected we'll need more information. Which distribution are you using? How did you install the fglrx-driver and which version? Please post the output of "uname -a".

Note that after the installation of the fglrx-driver you'll have to do two things, first run "aticonfig --initial" as root, second reboot the system.


grubber33 05-05-2011 11:43 AM

3 Attachment(s)
Adam - According to a few sources via google, yes, and I've tried a kernel with the option for support both enabled and disabled. I'll attach my current configuration file.

Markus - I'm using gentoo. Drivers were installed via emerge ati-drivers. I've tried both stable and unstable/latest with the same result. Stable is 11.3, latest is 11.4.

uname -a output: Linux blackwaterpark 2.6.37-gentoo-r4 #10 SMP Thu May 5 04:28:04 EDT 2011 x86_64 Intel(R) Core(TM) i7 CPU Q 740 @ 1.73GHz GenuineIntel GNU/Linux

I've run aticonfig --initial and rebooted several times to no avail. I will attach my dmesg output with the xorg.conf file that aticonfig --initial generates, as well as my kernel config file.

Just FYI, I've tried several guides from different sites with multiple kernel configurations, etc. which never worked, I'll link to them so you can get a better idea of what hasn't worked. Hopefully it's helpful. +

None of the troubleshooting info helped either.

Also, there's been an interesting post in my identical thread over on the gentoo forums. Here's a link: . The part about the ucode is of particular interest because it's been set up the way the first guide I linked describes, whereas the poster in that forum claims I need to remove all of it. I will go and give his post a whirl and post results/new info here!

Thanks in advance!

adamk75 05-05-2011 11:47 AM


Originally Posted by grubber33 (Post 4347539)
Adam - According to a few sources via google, yes, and I've tried a kernel with the option for support both enabled and disabled. I'll attach my current configuration file.

Well according to everything I've seen, fglrx won't work with switchable graphics if you can't disable the onboard (usually Intel) GPU via the computers BIOS.


markush 05-05-2011 02:23 PM

Well, I have a HD-5470 in my Samsung-laptop. In the first time, when the Laptop as well as the graphicsadapter was new I had many problems. My xserver crashed often due to problems with the fglrx-driver. I had less problems with the newer drivers.

There are two things you can do. First unmerge the atidriver and download the latest driver from the ATI-site. Build it on your system and don't forget to run aticonfig --initial and reboot. Note that the ATI-installer will blacklist the radeon-kernelmodule (did you check that it is blacklisted now, maybe there is one reason for your problems).

If this doesn't help, I'd recommend to uninstall the fglrx-driver, unblacklist the radeon-kernelmodule and try this one. Note that I'm using the radeon-module yet without any problems, only thing I changed was to change from OpenGL to XRender.


grubber33 05-05-2011 02:44 PM

The suggestion over at the Gentoo forums worked perfectly but thank you guys for your suggestions!


markush 05-05-2011 03:01 PM

This is an interesting solution. Maybe you'll describe it in short here and mark the thread as "SOLVED".


All times are GMT -5. The time now is 07:03 AM.