LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-29-2004, 10:58 AM   #1
Aeiri
Member
 
Registered: Feb 2004
Posts: 307

Rep: Reputation: 30
ATI FireGL Drivers for WineX, Uninstalling mesa?


I'm on Slackware 9.1, trying to get some games working on WineX. I'm on an ATI Radeon 9200 with FireGL Drivers installed and working. I have the native linux Quake3 installed and working perfectly, so I know the drivers are installed right.

When I try to run a game in WineX, the monitor receives no input, and I have to Ctrl+Alt+Backspace and restart X to get back in. I think this is because the mesa GL drivers are still installed, and WineX is trying to load those and not the ATI FireGL drivers.

When I run "locate libGL", it comes up with:

Quote:
/usr/lib/libGL.so.1
/usr/lib/libGL.so
/usr/X11R6/lib/libGL.so.1
/usr/X11R6/lib/libGL.a
/usr/X11R6/lib/libGL.so.1.2
/usr/X11R6/lib/libGLU.so.1.3
/usr/X11R6/lib/modules/extensions/libGLcore.a
/usr/X11R6/lib/libGLU.so
/usr/X11R6/lib/libGLU.so.1
/usr/X11R6/lib/libGL.so
/usr/X11R6/lib/libGLU.a
/usr/X11R6/lib/libGLw.a
I don't know which one of those is the mesa GL drivers, I don't want to delete the wrong ones. I know I installed the FireGL drivers in the X11R6 directory, but other people are saying that the X11R6 directory should have the mesa drivers, and any other folders should have your other drivers.

"removepkg mesa" says that the lib isn't installed, and when I "ls /var/log/packages", it isn't in the list.


How would I tell which one is mesa so I can uninstall it?

Thanks.
 
Old 02-29-2004, 03:21 PM   #2
Aeiri
Member
 
Registered: Feb 2004
Posts: 307

Original Poster
Rep: Reputation: 30
I tried changing the driver settings in fglrxconfig to be in compatible mode (for Wine/WineX/emulators), but that didn't do anything...

I tried removing the mesa drivers, but that made me have to reinstall Slack (without formatting) again to get the files back...

I have no clue what the problem is now, could SOMEONE help?
 
Old 04-10-2004, 02:53 PM   #3
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
try to disable dga
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Drivers... stuck in Mesa. indiglopulse Linux - Hardware 6 11-14-2004 05:26 PM
ATI FireGL X1 drivers for AMD64 ??? gattumarrudu Linux - Hardware 4 08-26-2004 08:09 AM
mesa dri or ati proprietatry drivers? shanenin Linux - Software 1 07-08-2004 04:49 AM
ATI 9700pro, Mandrake 9.1, FireGL 4.3 drivers - help! pablo0713 Linux - Hardware 1 06-23-2003 01:15 PM
ATI fireGL drivers messing with my Consoles peter72 Linux - Hardware 0 01-29-2003 07:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration