LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ATI FireGL Drivers for WineX, Uninstalling mesa? (https://www.linuxquestions.org/questions/linux-software-2/ati-firegl-drivers-for-winex-uninstalling-mesa-151864/)

Aeiri 02-29-2004 11:58 AM

ATI FireGL Drivers for WineX, Uninstalling mesa?
 
I'm on Slackware 9.1, trying to get some games working on WineX. I'm on an ATI Radeon 9200 with FireGL Drivers installed and working. I have the native linux Quake3 installed and working perfectly, so I know the drivers are installed right.

When I try to run a game in WineX, the monitor receives no input, and I have to Ctrl+Alt+Backspace and restart X to get back in. I think this is because the mesa GL drivers are still installed, and WineX is trying to load those and not the ATI FireGL drivers.

When I run "locate libGL", it comes up with:

Quote:

/usr/lib/libGL.so.1
/usr/lib/libGL.so
/usr/X11R6/lib/libGL.so.1
/usr/X11R6/lib/libGL.a
/usr/X11R6/lib/libGL.so.1.2
/usr/X11R6/lib/libGLU.so.1.3
/usr/X11R6/lib/modules/extensions/libGLcore.a
/usr/X11R6/lib/libGLU.so
/usr/X11R6/lib/libGLU.so.1
/usr/X11R6/lib/libGL.so
/usr/X11R6/lib/libGLU.a
/usr/X11R6/lib/libGLw.a
I don't know which one of those is the mesa GL drivers, I don't want to delete the wrong ones. I know I installed the FireGL drivers in the X11R6 directory, but other people are saying that the X11R6 directory should have the mesa drivers, and any other folders should have your other drivers.

"removepkg mesa" says that the lib isn't installed, and when I "ls /var/log/packages", it isn't in the list.


How would I tell which one is mesa so I can uninstall it?

Thanks.

Aeiri 02-29-2004 04:21 PM

I tried changing the driver settings in fglrxconfig to be in compatible mode (for Wine/WineX/emulators), but that didn't do anything...

I tried removing the mesa drivers, but that made me have to reinstall Slack (without formatting) again to get the files back...

I have no clue what the problem is now, could SOMEONE help?

leadazide 04-10-2004 03:53 PM

try to disable dga


All times are GMT -5. The time now is 07:03 AM.