-   Linux - Software (
-   -   ATI drivers on Slackware (

c_olin3404 05-21-2005 08:05 PM

ATI drivers on Slackware
I'm trying to get my ATI drivers installed, I folowed the directions from here.

here is part of the log when i tried a startx:


(II) LoadModule: "fglrx"
(II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for, module version = 8.12.10
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.6
(II) UnloadModule: "fglrx"
(II) Unloading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 6.8.1, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "Keyboard"
(WW) Warning, couldn't open module Keyboard
(II) UnloadModule: "Keyboard"
(EE) Failed to load module "Keyboard" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

The tutorial on how to set up ATI drivers on slackware is pretty iffy, some of the commands didnt work and stuff... are there any other tuts on how to install ATI drivers on slackware??


c_olin3404 05-22-2005 12:01 AM

any help? :(

c_olin3404 05-22-2005 01:35 AM

I successfully got it started... maybe..

I followed a tut and did all the magic commands, and eventualy did 'fglrxconfig' and set it up the right way. then restarted the X server and it worked. BUT, how do i know what config file is loaded when i do startx? becauses there is always the Xorg.conf file in the /etc/X11/ directory.

And plus, all graphic apps are running extremly slow, so I doubt it is workign.. How do I ensure that my driver is running? :(

__J 05-22-2005 01:41 AM

type "glxinfo" in a console and see if direct rendering is enabled

c_olin3404 05-22-2005 09:45 PM

direct rendering is not enabled :(.. How do I enabled it?

ride153 05-22-2005 10:10 PM

not sure what you're doing wrong but this is what i did.

rpm2targz fglrx*.rpm
tar -xvzf fglrx*.tar.gz -C /

cd /usr/lib/modules/fglrx/build_mod
cd ..

The next step is to Configure your X server:

after driver install logout and login as a user NOT root

c_olin3404 05-22-2005 11:36 PM

but after i do fglrxconfig and save it, it loads up as the default Xorg.conf file..

ride153 05-23-2005 07:42 AM

i would say try running fglrxconfig again it should write over the default Xorg.conf file. make sure you have write permissions to that file.

c_olin3404 05-23-2005 11:52 AM

I manually overwrote xorg.conf with X86Config-4 and on startx it said "fglrx module not found" and "cannot load driver"

and now im sad :(

Any suggestions at all? I would really like to get this running

__J 05-23-2005 12:23 PM

where did the XF86Config-4 come from?

are you using the xorg ati drivers ( unless you run an older slackware) ?

also, can you manually insert the frglx module?

c_olin3404 05-23-2005 12:28 PM

it said to get xfree version from

and it wrote XF86Config-4 at the end of fglrxconfig

am I supposed to get xorg version of ati drivers?

__J 05-23-2005 12:32 PM

depends on what version of slack you are running, in a console:


/usr/X11/bin/X -version

will give you what version of the X server you are using.

also, you cannot go out and follow random guides, make sure they apply first. if that guide was written for slack 9, some things might not apply for slack 10.1 ( this applies for all distro's , there are alot of old guides floating around on the net).

c_olin3404 05-23-2005 12:36 PM


X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.29 i686 [ELF]
Current Operating System: Linux sexy_blue 2.4.29 #6 Thu Jan 20 16:30:37 PST 2005 i686
Build Date: 23 January 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present

should i try the version of the ATI drivers?

__J 05-23-2005 12:44 PM

wouldn't be a bad idea, remove the other one first, make sure it builds correctly and re-run frglxconfig and see if that helps.

c_olin3404 05-23-2005 12:56 PM

how can i remove everything that i have done, so i can get a clean start?

All times are GMT -5. The time now is 11:37 PM.