LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-21-2004, 05:49 AM   #1
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Rep: Reputation: 30
Question ATI drivers


hi i have installed doom 3 on linux but with me having an ATI graphics card it doesnt work, so i went ont the ATI site to download some new ones

http://www.ati.com/support/drivers/l...eon-linux.html

and it told me to download a file called Check.sh to find out which version of xfree86 i have but when i run the in the konsole i get the following message

=====================================================================
ATI Technologies
=====================================================================
Your possibly not running this script from the console
or maybe you simply dont have the console ownership.
Unable to determine XFree86 Version. Stopping now.


why doesnt this work?

with it not working i tried downloading all the driver one by one and seeing if they worked but i couldnt even install them net alone test them

i got the following message or similar one for each driver i tried to install

error: Failed dependencies:
/bin/sh is needed by fglrx-4.1.0-3.14.6
ld-linux.so.2 is needed by fglrx-4.1.0-3.14.6
libX11.so.6 is needed by fglrx-4.1.0-3.14.6
libXext.so.6 is needed by fglrx-4.1.0-3.14.6
libc.so.6 is needed by fglrx-4.1.0-3.14.6
libdl.so.2 is needed by fglrx-4.1.0-3.14.6
libm.so.6 is needed by fglrx-4.1.0-3.14.6
libpthread.so.0 is needed by fglrx-4.1.0-3.14.6
librt.so.1 is needed by fglrx-4.1.0-3.14.6
libc.so.6(GLIBC_2.0) is needed by fglrx-4.1.0-3.14.6
libc.so.6(GLIBC_2.1) is needed by fglrx-4.1.0-3.14.6
libc.so.6(GLIBC_2.1.3) is needed by fglrx-4.1.0-3.14.6
libm.so.6(GLIBC_2.0) is needed by fglrx-4.1.0-3.14.6
libpthread.so.0(GLIBC_2.0) is needed by fglrx-4.1.0-3.14.6
librt.so.1(GLIBC_2.2) is needed by fglrx-4.1.0-3.14.6

i used teh following command when trying to install rpm -Uh --force <ati_package_name>.rpm which is the one off the ATI website,

is this error with it been an RPM package as i use slackware 10, and i dont realy know how to use an RPM as i hav never used them befor, if it is with it been an RPM does any one have any ideas on what i should do?

thanks for any help

berrance
 
Old 11-21-2004, 06:11 AM   #2
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Original Poster
Rep: Reputation: 30
i have just come accross this while googling

http://www.linuxquestions.org/questions/history/206141

i dont know if it works yet as i dont know how to save a file and exit "joe" an editing program in the command line! can ant one help please
 
Old 11-21-2004, 07:12 AM   #3
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Original Poster
Rep: Reputation: 30
right iv got the drivers working at long last but now i cant get openGL to work so i thought i would re-install it but can i hell find it to download of the ati site! i can find firegl but thats about it. does any body know where i can got open GL for a ATI RADION 9200 or ar they included in the drivers?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 07:52 PM
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 10:08 AM
SuSE 9.1 - ATI Mobility 9600 (M10) - ATi Drivers 3.9.0 Beaviis Linux - Hardware 3 06-04-2004 12:51 PM
ATI Drivers imroberts Mandriva 1 11-28-2003 07:26 PM
Red Hat9 + ATi Drivers + nForce2 Drivers sturreal Linux - Newbie 2 10-07-2003 07:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration