-   Linux - Software (
-   -   Ati 3.7.0 driver installation (

PawnsharK 03-09-2004 01:46 PM

Ati 3.7.0 driver installation

I am an uber noob to linux and I am suprized I got this far. Anyway, I am having trouble with a step in the ati installation. I have printed out the (23 page!) readme and I am at part 2.4, titled "Generating a customized kernel module". When the readme says "you must build the configured soruces of your kernel at /usr/src/linux -this is allowed to be a symlink", I am totally stumped at this point. Well, I tried running the under the directory /lib/modules/fglrx/build_mod subdir and this is my make.log

ATI module generator V 2.0
build_date =Tue Mar 9 13:45:00 EST 2004
uname -a =Linux 2.4.22-1.2174.nptl #1 Wed Feb 18 16:38:32 EST 2004 i686 athlon i386 GNU/Linux
uname -s =Linux
uname -m =i686
uname -r =2.4.22-1.2174.nptl
uname -v =#1 Wed Feb 18 16:38:32 EST 2004
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel)
drwxr-xr-x 12 root root 4096 Mar 9 12:34 /usr/include
total 8
drwxr-xr-x 2 root root 4096 Mar 9 12:34 ATI
drwxr-xr-x 2 root root 4096 Mar 9 12:44 linux
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h

I'm guessing that the directory doesn't exist but I don't know what to do from here. I'm thinking I missed a step somewhere, but I really need help on what do to from here. :confused:

aacovergaauw 03-10-2004 05:03 AM

What is kernel version do you have and how does your /usr/src directory look like?

PawnsharK 03-10-2004 10:33 AM


After a day and a half straight trying to understand how to install it I finally did it. Accoding to the last post, my /usr/src directory was empty and I eventually went to mirror sites and downloaded the kernel source rpm from the updates folder. Then I installed the rpm and continued the and so forth. If anyone else has this same problem I will be more than honored to post more in detail.

Pretty much I need to stop doing this :cry: and do more of this :study:

mckooter 03-31-2004 06:38 PM

Okay Ive been working with this problem for a while. Reading posts on here has got me up to the point where it says

you may need to adjust your symlinks
I installed SuSE 9.0 Pro then couldnt get the video drivers to work. From reading this realized I needed the source package, installed that. Now apparently my symlinks are wrong, I cant quite figure out how to adjust them to be correct. The entire error is:


ATI module generator V 2.0
cat: /usr/src/linux/include/linux/version-*.h: No such file or directory
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as ""
instead of "2.4.21-199-athlon".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux

any ideas on how to fix this.

Pwnz3r 03-31-2004 06:42 PM

Fixing the sym link means to make the /usr/src/linux symbolic link point to the sources for you current kernel. Distros should really not matter when it comes to getting things working.

mckooter 03-31-2004 06:45 PM

yes, I kinda got that, but im quite new, and I have read all over and can not find the way to do that. I havent been able to figure out where the symbolic link is and how to change it. Thanks :) (sorry to be a noob i would just be quite excited if i could actually have a linux system that works well)

mckooter 03-31-2004 08:50 PM

I know it should be simple. Im trying to read around I typed this:

ln -s 2.4.21-199-athlon /usr/src/linux/include
and I am assuming that is wrong.

I know its something to do with ln -s, thats where i am lost though.

Pwnz3r 03-31-2004 09:06 PM

It should be:

ln -s path-to-kernel-sources /usr/src/linux


ln -s path-to-kernel-sources /usr/src/linux/include

That should make it better.

mckooter 03-31-2004 09:18 PM

okay I admit im an idiot

I tried:

ln -s 2.4.21-199-athlon /usr/src/linux
and recieved the same error

then tried:


ln -s /usr/src/linux-2.4.21-99 /usr/src/linux
then immediately got back the error:

ln: `/usr/src/linux/linux-2.4.21-99': File exists
then for kicks i tried:

n -s /usr/src/linux-2.4.21-99-include /usr/src/linux
and got back the same error as before which was:


ATI module generator V 2.0
cat: /usr/src/linux/include/linux/version-*.h: No such file or directory
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as ""
instead of "2.4.21-199-athlon".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux

I was logged in as root the whole time. I feel like I am so close but so far away.

mckooter 04-02-2004 02:40 PM

I know this is simple im still not getting it though. What am I typing wrong?

mckooter 04-02-2004 04:52 PM

Okay figured that part out now I needed to configure my kernel source. And next I got an error I was told to goto /lib/modules/fglrx and type sh

And I did then i got the error:

- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in /lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o
- trying a sample load of the kernel module
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol remove_proc_entry_R5c65f2d8
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol add_wait_queue_Raf1b06bf
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol register_chrdev_Rb742e083
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol remove_wait_queue_Ra0616a3b
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol irq_stat_R76939af5
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol mem_map_R4869e273
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol contig_page_data_R66468ee1
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol unlock_page_Rcb5a141b
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol create_proc_entry_R8dd8692b
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol __alloc_pages_Rb9835fec
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol init_mm_R539026bd
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol highmem_start_page_R996a6e35
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: unresolved symbol __free_pages_R9cfa89f8
Hint: You are trying to load a module without a GPL compatible license
      and it has unresolved symbols.  Contact the module supplier for
      assistance, only they can help you.

/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.21-199-athlon/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed

I went to the ati website to see what this was about and it said for unresolved symbols:


"unresolved symbol" error message during kernel module install

The information in this article applies to the following configurations:
ATI Proprietary Linux Drivers

The following error message may appear while trying to install the fglrx kernel module:

: unresolved symbol

This error (or similar) occurs when the kernel source code is not installed properly or does not match the currently installed kernel.

In some cases, the kernel source is the correct version, but the necessary dependencies are missing. In this case, it may be possible to workaround the error as follows:

1. cd /usr/src/linux

2. make cloneconfig && make dep
(note any errors)

3. restart the system

4. rebuild and reinstall the kernel module
thats what I did to configure the source, the "cloneconfig && make dep" so apparently I am still doing it wrong

All times are GMT -5. The time now is 04:55 AM.