LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-26-2006, 03:28 PM   #1
setkos
LQ Newbie
 
Registered: Mar 2006
Posts: 21

Rep: Reputation: 15
aterm (with fluxbox+transparency) and mc


Hello,

I don't know how to describe the problem, but i will try. The borders in mc launched in aterm look terrible(this is something like "A"). I don' t know what to do, because there is very similar problem when I use mc via SSH...
 
Old 03-26-2006, 04:08 PM   #2
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
It might be the value of the TERM environment variable. What does "set | grep TERM" tell you? If I set the TERM variable to "linux" I get all of those funky A's in mc. Mine is normally set to "xterm."

-geo
 
Old 03-27-2006, 06:32 AM   #3
setkos
LQ Newbie
 
Registered: Mar 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you, it is almost working, but when I press any of the arrows keys, I recive A or B or C or D in mc's command line, and I am not able to move inside mc.
 
Old 03-27-2006, 12:00 PM   #4
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
Hmmm, maybe that has to do with the settings of mc rather than the terminal settings. How does everything work in another terminal program like xterm or konsole? And does mc work outside of fluxbox on the command line? Do you have an unusual keyboard?

-g
 
Old 03-30-2006, 05:35 PM   #5
setkos
LQ Newbie
 
Registered: Mar 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Hello,

This are results of my tests(I have normal keyboard):

SSH:
TERM=xterm
MC's borders:with "funnky" a
MC' colours: blue(standard)

TERM=xterm.
MC's borders:with |
MC' colours: black and white
Arrows keys in MC don't work( when I press any of the arrow keys, I have recived A or B or C or D in MC's command line)

FLUXBOX with TA:
xterm:
TERM=xterm
MC's borders:normal(standard)
MC' colours: blue(standard)

TERM=xterm.
MC's borders:with |
MC' colours: black and white
Arrows keys in MC don't work( when I press any of the arrow keys, I have recived A or B or C or D in MC's command line)

aterm:
TERM=rxvt
MC's borders:with double "funnky" a
MC' colours: blue(standard)

TERM=xterm
similar result like with rxvt
MC's borders:with double "funnky" a
MC' colours: blue(standard)

TERM=xterm.
MC's borders:with |
MC' colours: blue(standard)
Arrows keys in MC don't work( when I press any of the arrow keys, I have recived A or B or C or D in MC's command line)
 
Old 03-30-2006, 05:50 PM   #6
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
Just came across this: there is a "learn keys" function in mc. Open up the top menu bar and go to options (F9 and then "O" if you can't use your arrow key) and then select "learn keys." I'm not sure exactly what it does, but you are supposed to press each of the keys listed in order to configure them for use. Maybe that will tell the program to pay attention to the arrow keys.

-geo
 
Old 04-01-2006, 12:36 PM   #7
setkos
LQ Newbie
 
Registered: Mar 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you, it is working now, but....MC with TERM=xterm. via SSH is black and white(with TERM=xterm there are standard colours),when with aterm it is working with standard colours. Mayby you will help me with this .
 
Old 04-02-2006, 06:50 PM   #8
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
I dunno if this helps but there is also a COLORTERM environment variable you might mess around with. The mc man pages also deal with the issue of color and it seems that not all terminals support color mc. Did you get your arrow key issue fixed? Strangely enough I am now having that same problem -- ABCD instead of arrows but only when I am in aterm using vi in insert mode. In order to jump line to line I have to be in command mode. Weird. I'll have to experiment and see what happens...

-geo
 
Old 04-07-2006, 06:07 PM   #9
setkos
LQ Newbie
 
Registered: Mar 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Yes, MC works fine after lerning keys. In aterm(in Fluxbox) everything looks fine, keys are working perfectly, but when I use xterm. in SSH connection, MC is in b&w, keys work, but I am not able to use PGUP/PGDN in man...I've checked: my vi works without keys issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aterm transparency problem evilfix Linux - Software 3 02-08-2006 07:34 PM
aterm transparency only on workspace 1!! poto_floyd Linux - Software 6 12-14-2005 09:30 PM
fluxbox + aterm + rox transparency issues geomatt Linux - Software 0 08-10-2005 10:45 AM
aterm and true transparency oxblood Linux - Software 9 07-31-2005 03:13 AM
aterm transparency doesn't work. rundmg Linux - Software 1 10-20-2004 10:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration