LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2014, 12:21 PM   #1
kjcook
LQ Newbie
 
Registered: Aug 2014
Posts: 5

Rep: Reputation: Disabled
aspell - No word lists can be found for the language


I am trying to get aspell to work for me.

I have tried this:

-sh-4.1$ /usr/bin/aspell -a -lang=en_US < dead.letter
WARNING: Unable to enter Nroff mode: Unknown mode: "nroff".
Error: No word lists can be found for the language "ang".

So I thought well maybe the dictionary is not installed:

-sh-4.1$ aspell dump dicts
en
en-variant_0
en-variant_1
en-variant_2
en-w_accents
en-wo_accents
en_CA
en_CA-variant_0
en_CA-variant_1
en_CA-w_accents
en_CA-wo_accents
en_GB
en_GB-ise
en_GB-ise-w_accents
en_GB-ise-wo_accents
en_GB-ize
en_GB-ize-w_accents
en_GB-ize-wo_accents
en_GB-variant_0
en_GB-variant_1
en_GB-w_accents
en_GB-wo_accents
en_US
en_US-variant_0
en_US-variant_1
en_US-w_accents
en_US-wo_accents


What am I missing?
 
Old 08-05-2014, 12:28 PM   #2
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,680

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Did you type the number '1' accidentally instead of the letter 'l'?
 
Old 08-05-2014, 01:38 PM   #3
kjcook
LQ Newbie
 
Registered: Aug 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
No I didn't. It is an L. Here is what I get if it were a one "1".

-sh-4.1$ /usr/bin/aspell -a --1ang=en_US < dead.letter
Error: The key "1ang" is unknown.


I did not notice the "ang". I don't believe I have gotten that before. I logged out/in and tried it again and this is what I have been getting:

-sh-4.1$ /usr/bin/aspell -a --lang=en_US < dead.letter
WARNING: Unable to enter Nroff mode: Unknown mode: "nroff".
Error: No word lists can be found for the language "en_US".


Thanks

Last edited by kjcook; 08-07-2014 at 04:43 PM.
 
Old 08-13-2014, 06:05 PM   #4
kjcook
LQ Newbie
 
Registered: Aug 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
No Guru on Aspell that can tell me what I am doing wrong?
 
Old 08-13-2014, 06:23 PM   #5
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,680

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
I think I missed something onbvious. Shouldn't the "lang" optiom have two dashes before it i.e. "--lang="?
 
Old 08-14-2014, 08:27 AM   #6
kjcook
LQ Newbie
 
Registered: Aug 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
It does.


-sh-4.1$ /usr/bin/aspell -a --lang=en_US < dead.letter
WARNING: Unable to enter Nroff mode: Unknown mode: "nroff".
Error: No word lists can be found for the language "en_US".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aspell Error: No word lists can be found for the language "en_US" centguy Linux - Software 5 02-20-2012 12:35 AM
[SOLVED] Aspell proposing words like in MS Word? Xeratul Linux - Software 1 01-06-2012 09:41 AM
want to add a word in front if found another word coolplanet Linux - Newbie 8 05-01-2009 12:32 PM
LXer: Unique Sorting Of Lists And Lists Of Lists With Perl For Linux Or Unix LXer Syndicated Linux News 0 09-05-2008 01:50 PM
Word Lists (please help) Jmcatch742 General 26 06-13-2005 08:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration